Closed Bug 51020 Opened 20 years ago Closed 7 years ago

Macromedia Dreamweaver Evangelism Tracking - MM_showHideLayers, MM_findObj, et al

Categories

(Tech Evangelism Graveyard :: English US, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ubl, Unassigned)

References

()

Details

(Keywords: meta, top500, Whiteboard: [author])

Hi,

Macromedia Dreamweaver is one of the best WYSIWYG Web-Editors around. We dont 
need a discussion about the need of those editors here. A fact is that 
Dreamweaver's code is a lot better than code written by the majority of people 
who hand code and its rountrip-html capabilities are wonderful.
However, its JavaScript, particularly that concerned with moving/hiding/whatever 
layers still uses document.layer. Dreamweaver 3 was a step forward in the way 
that it uses object detection now, so you dont get error messages in Moz anymore, 
but it just doenst work, because W3 DOM is not recognized.

As far as I understand Dreamweaver's JavaScript, it would probably be enough to 
rewrite this single function to be DOM compliant:

function MM_findObj(n, d) { //v3.0
  var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
  if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=
d.forms[i][n];
  for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=
MM_findObj(n,d.layers[i].document); return x;
}

Maybe someone can give it a try. The product is available for 30 day trial at 
macromedia.com

Have fun,

malte
You've got to be kidding!  Dreamweaver produces the most bloated, non-compliant
HTML and JS of any HTML editing product available today.  I know because I have
tried them all.  Dreamweaver cannot produce valid HTML for even the simplest
documents.

At any rate, Mozilla will not support layers, ever.  If Dreamweaver wishes to
work with Mozilla and other future browsers, they will have to update their
product to comply with internet standards.

Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Just wondered by looking at invalid bugs. Thought I would mention that DW code 
has never failed a W3C validator in my experience. You must be thinking of 
Frontpage.
Yeah, thats true.

First Dreamweaver's JS has gotten better and its HTML is near to perfect. You 
really must be referring to frontpage.

Jeffrey, maybe you know which component we are in. Wouldn't it be very important 
to have the editor which is by far the best selling in professional web design, 
work with NS6. That would probably solve most of the problems with 
evangelization in an instant.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
this is Macromedia's feedback:
###################################################################


Malte,
 
We write Dreamweaver so it can cover as many users and browsers as
possible. The code level has to do with when the specs were released and
development schedule for Dreamweaver. Netscape 6 has just been released,
well after the release of DW3.
There will be no significant update until the next release.
Good luck.
Sincerely,
Donald Booth
Macromedia Tech Support



-----Original Message-----
From: agentreply@macromedia.com [mailto:agentreply@macromedia.com]
Sent: Thursday, August 31, 2000 2:19 AM
Subject: Macromedia customer service request - Product
information[PSD20000912000035451810033]


Sender          : ubl@schaffhausen.de
Tracking Number : PSD20000912000035451810033
Pool            : TS - Presales - DW
Sent to         : imccscontact@macromedia.com
Date            : 08/31/00 02:14
---

Forwarded by: Nathan Exline

(no comments entered)
---

Forwarded by: Nathan Exline

(no comments entered)
---

Forwarded by: CustomerService AutoAgent

Forwarded By Customer Support Robot
---


The following information was submitted on the Macromedia Customer Support
E-mail Form:

Name                : Malte Ubl
Email Address       : ubl@schaffhausen.de
Voice Phone         : +49 4121 472946
Issue Concerns      : Product information

Issue follows below
----------------------------------------------------------------------------
----
Hi,

we are interested in purchasing a large number of dreamweaver licenses. We
are very satisfied with the product itself, however, we noticed that it
lacks support for browser which use the W3 DOM like Netscape 6.

When are you going to include this feature? We hope you will fix this soon
and dont wait until the next major release.

Thank You,

Malte Ubl
Schaffhausen | Interactive



<<<----------------below this line is for some script to
parse---------------->>>
Malte Ubl,ubl@schaffhausen.de,+49 4121 472946,Product information,Hi,

we are interested in purchasing a large number of dreamweaver licenses. We
are very satisfied with the product itself, however, we noticed that it
lacks support for browser which use the W3 DOM like Netscape 6.

When are you going to include this feature? We hope you will fix this soon
and dont wait until the next major release.

Thank You,

Malte Ubl
Schaffhausen | Interactive,Mozilla/4.0 (compatible; MSIE 5.0;
Mac_PowerPC),194.25.151.7,,http://www.macromedia.com/support/email/cscontact
/main.cgi,

Although Macromedia hasnt been very cooparative on this matter, there is a very 

very workaround for Dreamweaver's problems with the DOM:



Just replace this function:

function MM_findObj(n, d) { //v3.0

  var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {

    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}

  if(!(x=d[n])&&d.all) x=d.all[n]; 

  for(i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];

  for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=

MM_findObj(n,d.layers[i].document); return x;

}



with this function:

function MM_findObj(n, d) { //v3.0

  var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {

    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}

  if(!(x=d[n])&&d.all) x=d.all[n]; 

  if(!(x=d[n])&&d.getElementById(n)) x=d.getElementById(n) // the new line

  for(i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];

  for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=

MM_findObj(n,d.layers[i].document); return x;

}



Only one line has changed but everything works now.

Assignee: blakeross → evangelism
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
Dreamweaver 4 supports Mozilla. I am going to convert this into a tracking bug
for all sites that use old versions of Dreamweaver and should be contacted to
upgrade their sites to use Dreamweaver 4 generated code.

Changing OS to all, uping priority to P1 since DW code is used in lots of sites.

See http://www.macromedia.com/software/dreamweaver/ for the latest version.

If you find a site that uses old pre Dreamweaver 4 code, please

1.  file an evangelism bug on the site.
2.  make the bug block this bug so we can easliy track Dreamweaver issues
3.  send the owner of the site an email pointing them to the latest version of
Dreamweaver.
4.  note in the bug that you sent the letter
5.  mark [TOOL][DREAMWEAVER] in the status whiteboard to allow us to run queries
as well. 

Thanks,
Bob

Status: NEW → ASSIGNED
OS: Mac System 8.5 → All
Priority: P3 → P1
Whiteboard: [TRACKING][TOOL][DREAMWEAVER]
Depends on: 73467
Depends on: 41471
Depends on: 72297
Depends on: 65812
Depends on: 18313
Depends on: 59671
Depends on: 80780
Depends on: 81522
Keywords: meta
Depends on: 34867
Depends on: 67532
Depends on: 87549
Depends on: 89949
Depends on: 90944
Depends on: 91573
Depends on: 90615
Depends on: 91023
Depends on: 92363
Depends on: 92682
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
Depends on: 95516
Blocks: 57456
follow up with these sites by 0.9.5
Target Milestone: --- → mozilla0.9.5
Summary: Dreamweaver generated JavaScript → Evangelism - Dreamweaver generated JavaScript
Depends on: 69197
Depends on: 69034
Depends on: 66075
Depends on: 67689
Depends on: 99750
Depends on: 99891
Depends on: 100690
-> 0.9.6, need to follow up on these asap
Target Milestone: mozilla0.9.5 → mozilla0.9.6
Summary: Evangelism - Dreamweaver generated JavaScript → WRMB: Evangelism - Dreamweaver generated JavaScript
Whiteboard: [TRACKING][TOOL][DREAMWEAVER] → [bugscape: 7645][TRACKING][TOOL][DREAMWEAVER]
Summary: WRMB: Evangelism - Dreamweaver generated JavaScript → Evangelism - Dreamweaver generated JavaScript
Whiteboard: [bugscape: 7645][TRACKING][TOOL][DREAMWEAVER] → [bugscape: 7645][TRACKING][TOOL][DREAMWEAVER][wrmb]
Depends on: 89840
Blocks: 104766
This is the first of two spams.  Removing blockage by 104766.  Next will place
dependency on 104766.
No longer blocks: 104766
Apologies for the spam to everyone.
Depends on: 104766
Depends on: 97536
Depends on: 110104
No longer depends on: 110629
Depends on: 110629
Depends on: 111843
Depends on: 113047
Depends on: 54493
Depends on: 113672
-> authors
Component: US General → Authors
Depends on: 70802
Depends on: 118530
Depends on: 85700
Depends on: 88749
Depends on: 116031
Whiteboard: [bugscape: 7645][TRACKING][TOOL][DREAMWEAVER][wrmb] → [bugscape: 7645][TRACKING][TOOL][DREAMWEAVER][wrmb][aok]
Depends on: 112464
Depends on: 121902
Depends on: 99916
Keywords: evang500
Whiteboard: [bugscape: 7645][TRACKING][TOOL][DREAMWEAVER][wrmb][aok] → [bugscape: 7645][TRACKING][TOOL][DREAMWEAVER][wrmb]
Depends on: 69286
*** Bug 134622 has been marked as a duplicate of this bug. ***
Depends on: 134819
Depends on: 136018
macromedia long ago released a ns6 compat pack and dreamweaver mx has new
versions of many functions, somebody should verify those
Depends on: 141745
most of the dw functions works with gecko browsers.
that includes images rollovers, show|hide layers, etc
there are a few things that assume every browser is either IE or NS4, but the
key functions are fine.
Depends on: 131836
Depends on: 143288
Depends on: 168764
Depends on: 94644
Whiteboard: [bugscape: 7645][TRACKING][TOOL][DREAMWEAVER][wrmb] → [bugscape: 7645] [TRACKING] [TOOL] [DREAMWEAVER] [wrmb]
Depends on: 147216
Depends on: 151116
Depends on: 150706
Depends on: 113428
Depends on: 186978
Summary: Evangelism - Dreamweaver generated JavaScript → Macromedia Dreamweaver Evangelism Tracking - MM_showHideLayers, MM_findObj, et al
Depends on: 101155
Depends on: 113845
Depends on: 92844
Depends on: 87563
Depends on: 79068
I have a site with javascript menus made in MM firworksm When the menus drop
down in Mozilla the links work but the cursor doesnt change, and if i put my
cursor over the text in that link I get the text highlighter tool and the link
doesnt work, and on of my links is completely covered in text and that doesnt
work at all.

Does any bosy know that bug this is due to?
Alex, I would suggest opening a bug for your site. Include information on which
verion of fireworks you used in creating it, as well as information on which
Mozilla builds you used. Please read
http://www.mozilla.org/quality/bug-writing-guidelines.html to learn how to file
an effective bug report.
its not live yet, but when it is ill let you all know, oh and it seems to work
fine in opera
Depends on: 141267
Depends on: 98210
Depends on: 145292
Depends on: 146635
Depends on: 208783
tech evang june 2003 reorg
Assignee: bc → english-us
Status: ASSIGNED → NEW
Component: Authors → English US
QA Contact: zach → english-us
Whiteboard: [bugscape: 7645] [TRACKING] [TOOL] [DREAMWEAVER] [wrmb] → [author]
Depends on: 210129
reset milestones as irrelevant to tracking bugs.
Target Milestone: Nov → ---
Depends on: 234778
No longer depends on: 234778
Keywords: top500
do we want adobe to fix the old dreamweaver releases or are the ok with the current stuff they deliver ?
Michael, just current releases since expecting them to go back and fix arbitrarily old releases is unreasonable.
Given Firefox's current market share, I'm pretty sure that the current release outputs code that works in Firefox.
Great work everyone!
Status: NEW → RESOLVED
Closed: 20 years ago7 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.