If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Memory leak with Silk enabled and HW Acc disabled

VERIFIED WORKSFORME

Status

()

Firefox
General
--
major
VERIFIED WORKSFORME
3 years ago
2 months ago

People

(Reporter: Virtual, Assigned: mchang)

Tracking

({nightly-community})

Trunk
x86_64
Windows 7
nightly-community
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

STR:
1. enable Silk in about:config by changing to "true" these 3 preferences:
-gfx.vsync.compositor
-gfx.vsync.hw-vsync.enabled
-gfx.vsync.refreshdriver
2. disable GPU hardware acceleration in about:preferences (Options) by unchecking tick near "Use hardware acceleration when available" in "Advanced" tab in "General" subtab
3. Go to https://www.vsynctester.com/
4. Look how your RAM is being eaten by Firefox continuously
(Assignee)

Comment 1

3 years ago
Tested on OS X Yosemite.

Tried 4 configs gathering ram usage from activity monitor

Nightly w/o silk w/ hardware acceleration - ~240 mb usage
Nightly w/ silk w/ hardware acceleration - ~242 mb usage
Nightly w/o silk w/o hardware acceleration - ~258 mb usage
Nightly w/ silk w/o hardware acceleration - ~264 mb usage

So there does look like some memory usage increase with silk enabled and hardware acceleration disabled, but I can't reproduce a memory leak at least that's general across silk. Will test again on Windows 7.
(Assignee)

Updated

3 years ago
Assignee: nobody → mchang
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
Just tested on Windows 7. I am unable to reproduce this memory leak. This is on nightly 39.0a1 (2015-02-27).

Three configurations:
Nightly stock: ~100mb
Nightly silk + hw acceleration: ~100 mb
Nightly silk - hw acceleration: ~105mb

All ram usage gathered via the windows task manager. 

@Virtual_ManPL: Can you please test again? Also, after enabling or disabling each preference, please restart nightly as the options don't go into effect until after a restart. Thanks!
Flags: needinfo?(BernesB)
(Assignee)

Comment 3

3 years ago
Updated STR:

1. enable Silk in about:config by changing to "true" these 3 preferences:
-gfx.vsync.compositor
-gfx.vsync.hw-vsync.enabled
-gfx.vsync.refreshdriver
2. Restart Nightly
3. disable GPU hardware acceleration in about:preferences (Options) by
unchecking tick near "Use hardware acceleration when available" in
"Advanced" tab in "General" subtab
4. Restart nightly
5. Go to https://www.vsynctester.com/
6. Look how your RAM usage
Yep, most changes in about:config need a Firefox restart, I forgot to add it to STS, but one is enough. ;)
Flags: needinfo?(BernesB)
(Assignee)

Comment 5

3 years ago
Are you still encountering the memory leak? I haven't been able to reproduce it. Can you please list your system configuration? Thanks!
Flags: needinfo?(BernesB)
Yes, I can still reproduce it on latest Firefox Nightly 32bit.

whole PC specs:
CPU: Intel Core 2 Duo E6550 2,33@3,4GHz (default voltage, energy savings options like CPU Enhanced Halt (C1E) & CPU EIST Function (Enhanced Intel SpeedStep Technology) are disabled)
MOBO: Gigabyte GA-P35C-DS3R (latest BIOS version [F13d], FSB 333@486MHz, default voltages/timings/speeds, especially PCI-E blocked at 100MHz)
GPU: Palit (NE5X4600HD09F) NVIDIA GeForce GTX 460 v2 1GB GDDR5 (778/4008, 192bit) with latest 347.52 drivers
RAM: Kingston 2x 2GB DDR2 (1066@971MHz, default voltage=2,2V)
SOUND: Creative Sound Blaster Live! 5.1 with latest kX drivers (ASIO) 5.10.0.3552
PSU: Corsair VX550W
LCD: LG Flatron W2252TQ (60@76MHz [CVT-R], 1680x1050, 32bit)
SYS: Microsoft Windows 7 Professional [64bit] SP1 + all patches

more drivers info:
Chipset Software Installation Utility - 10.0.25 - drivers for motherboard
Rapid Storage Technology - 13.6.0.1002 - drivers for motherboard
LAN drivers - 7.091 -  for integrated Realtek 8111B on motherboard



Graphics section from about:support when bug occurs with Silk enabled and HW Acc disabled
Adapter Description	NVIDIA GeForce GTX 460 v2
Adapter Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM	1024
Device ID	0x1205
DirectWrite Enabled	false (6.2.9200.16571)
Driver Date	2-5-2015
Driver Version	9.18.13.4752
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic (OMTC)
Subsys ID	00000000
Vendor ID	0x10de
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GTX 460 v2 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0



Graphics section from about:support when bug didn't occurs with Silk disabled and HW Acc enabled
Adapter Description	NVIDIA GeForce GTX 460 v2
Adapter Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM	1024
Device ID	0x1205
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	2-5-2015
Driver Version	9.18.13.4752
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	00000000
Vendor ID	0x10de
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GTX 460 v2 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(BernesB)
(Assignee)

Comment 7

3 years ago
Created attachment 8572182 [details]
about:support hardware acceleration disabled
(Assignee)

Comment 8

3 years ago
Created attachment 8572184 [details]
about:support hardware acceleration enabled
(Assignee)

Comment 9

3 years ago
I still can't reproduce on both 64 and 32 bit builds, attached are my about:support configs. 

@Virtual_ManPL - If you have time, can you please try these things / answer these questions?

1) How long are you running the test for? There can sometimes be a few seconds until the GC kicks in and cleans everything up.
2) Can you try with just the vsync compositor, e.g set only these two to true:

gfx.vsync.compositor
gfx.vsync.hw-vsync.enabled

Leave gfx.vsync.refreshdriver to false. Does it still occur?

3) Likewise, can you please try with just the vsync refresh driver. eg set these two to true:

gfx.vsync.hw-vsync.enabled
gfx.vsync.refreshdriver

Leave gfx.vsync.compositor as false.

4) Can you get an about:memory profile of silk and hardware acceleration disabled and a second profile of silk disabled and hardware acceleration disabled.

5) Do you have any plugins / extensions? Can you try disabling them or also try creating a new test profile (http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows)?

Thanks!
Flags: needinfo?(BernesB)
Hmm, now I'm not able to reproduce it too, even going to Nightly build which it occurred, odd...
and user from forum isn't able to reproduce it too on latest Nightly (2015-03-04), but he said he was able to reproduce it on Nightly day before (2015-03-03).

I'm closing this as WORKSFORME and if anyone is still able to reproduce this issue, please reopen this bug.

I think it was probably due to:
-leaky addon, which was updated,
-Nightly bug which caused some addon to be leaky.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(BernesB)
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
Keywords: nightly-community
QA Contact: Virtual
You need to log in before you can comment on or make changes to this bug.