[meta] Enable Silk on Other platforms

RESOLVED FIXED in Firefox 40

Status

P2
normal
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

unspecified
2.2 S11 (1may)
ARM
All
Dependency tree / graph

Firefox Tracking Flags

(firefox40 fixed)

Details

(Whiteboard: [games:p2][platform-rel-Games], URL)

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Once we get silk working on b2g, let's align the refresh driver / compositor / input across the other platforms.

Updated

4 years ago
Blocks: 1080869
(Assignee)

Updated

4 years ago
Depends on: 552020
(Assignee)

Updated

4 years ago
Depends on: 1127151
(Assignee)

Updated

4 years ago
Duplicate of this bug: 689418
(Assignee)

Updated

4 years ago
Depends on: 1128165
(Assignee)

Updated

4 years ago
Assignee: nobody → mchang
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Depends on: 1129686
(Assignee)

Updated

4 years ago
Depends on: 1130136
(Assignee)

Updated

4 years ago
Depends on: 1133526
(Assignee)

Updated

4 years ago
Depends on: 1133527
(Assignee)

Comment 3

4 years ago
Try looks good on OS X + Windows with all of Silk enabled - https://treeherder.mozilla.org/#/jobs?repo=try&revision=aa339e4699fd
(Assignee)

Updated

4 years ago
Depends on: 1128690
(Assignee)

Updated

4 years ago
Depends on: 1135136
Is there a bug filed for graphical corruption/artifacts after enabling vsync?
(Assignee)

Comment 5

4 years ago
(In reply to Johannes Pfrang [:johnp] from comment #4)
> Is there a bug filed for graphical corruption/artifacts after enabling vsync?

Not at the moment, but you can file one as a dependent of this bug. What are you seeing?

You can also always disable it by setting these prefs to false on b2g:

gfx.vsync.hw-vsync.enabled
gfx.vsync.compositor
gfx.touch.resample
(Assignee)

Updated

4 years ago
Depends on: 1137905
(Assignee)

Updated

4 years ago
Blocks: 1138627
(Assignee)

Updated

4 years ago
Depends on: 1139090
(Assignee)

Updated

4 years ago
Depends on: 1140260
(Assignee)

Updated

4 years ago
Depends on: 1140723
(Assignee)

Updated

4 years ago
Depends on: 1144317
(Assignee)

Updated

4 years ago
Depends on: 1144321
(Assignee)

Updated

4 years ago
Depends on: 1144451
(Assignee)

Updated

4 years ago
Depends on: 1146942
(Assignee)

Updated

4 years ago
Depends on: 1149391
(Assignee)

Updated

4 years ago
Depends on: 1150727
(Assignee)

Updated

4 years ago
Depends on: 1151487
(Assignee)

Updated

4 years ago
Depends on: 1151488
(Assignee)

Updated

4 years ago
Depends on: 1151489
(Assignee)

Comment 7

4 years ago
Created attachment 8590884 [details] [diff] [review]
Consoildate silk preferences

Once bug 1151488 lands, silk will be on everywhere. Hardware vsync on b2g kit-kat, Windows w/ DWM, and OS X. Software vsync everywhere else. Consolidate all the preferences into one place.
Attachment #8590884 - Flags: review?(bugmail.mozilla)
(Assignee)

Updated

4 years ago
Blocks: 1133528
Comment on attachment 8590884 [details] [diff] [review]
Consoildate silk preferences

Review of attachment 8590884 [details] [diff] [review]:
-----------------------------------------------------------------

::: modules/libpref/init/all.js
@@ +4666,5 @@
>  #endif
>  
>  // Use vsync aligned rendering. b2g prefs are in b2g.js.
>  // Hardware vsync supported on windows, os x, and b2g.
>  // Linux and fennec will use software vsync.

I think just remove this entire comment block except for the first sentence. The rest of it may easily go out of date since people fiddling in other parts of the code may not update this. (The bits about b2g are already wrong/incomplete)
Attachment #8590884 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/1023edc0a85e
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S11 (1may)

Updated

3 years ago
Depends on: 1210261
Whiteboard: [games:p2]
Whiteboard: [games:p2] → [games:p2][platform-rel-Games]
You need to log in before you can comment on or make changes to this bug.