If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Trigger direct Firefox download from the "Non supported browser page"

VERIFIED FIXED in Firefox 40

Status

Hello (Loop)
Client
P2
normal
Rank:
23
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: RT, Assigned: standard8)

Tracking

unspecified
mozilla40
Points:
1
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox40 verified)

Details

(Whiteboard: [new users])

User Story

Currently, when clicking a Hello link on a non supported browser on a supported platform, a "Get Firefox" link is provided although this links redirects to https://www.mozilla.org/en-US/firefox/new/ where the user is presented another link to download Firefox.

60% of people hitting the "non supported browser" page click the "Get Firefox" link although only 16% of people on the Firefox download page actually download Firefox. We need to implement a direct download from the Hello page directly.

Acceptance criteria:
* Clicking the "Get Firefox" button triggers a Firefox download directly
* The Firefox download initiated is suitable for the users's platform and locale -  https://download.mozilla.org/?product=firefox-stub&os=<OS_USED_BY_LINK_CLICKER>&lang=<LOCALE_USED_BY_LINK_CLICKER>

Attachments

(2 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

3 years ago
Created attachment 8569309 [details]
Non supported browser page.png

Non supported browser page
(Reporter)

Updated

3 years ago
User Story: (updated)
(Reporter)

Comment 2

3 years ago
Shell, this one seems trivial and high impact, can we add it to Trello for implementation (may be a good first bug?).
Flags: needinfo?(sescalante)

Comment 3

3 years ago
put in backlog as P3 per guidelines https://wiki.mozilla.org/Firefox/Iterative_Hello_Development#Product_Backlog

RT and Gavin can move up if needed (while i'm out).  With team right now and 5 weeks for Fx39 in nightly - we should be able to take 30-37 bugs, based on historical performance and team size.

Knowing that - the prioritization of the bugs in the 20's and low 30's should be moved relative to each other...
Rank: 31
Flags: qe-verify+
Flags: needinfo?(sescalante)
Flags: firefox-backlog+
Priority: -- → P3

Comment 4

3 years ago
estimated 80% loss from clicking through 2 buttons to get to download - smaller change = high impact. ~1000/day.
Rank: 31 → 25
Priority: P3 → P2

Updated

3 years ago
Whiteboard: [new users]

Comment 5

3 years ago
moved up as this will be a quick fix / high impact (i was off - it's a 60% loss from having to click 2 buttons, which is more industry standard)
Rank: 25 → 23

Comment 6

3 years ago
I would not recommend do this and we can give you a direct download link that also provides instructions and that we can measure success rate.

Updated

3 years ago
Duplicate of this bug: 1149793

Comment 8

3 years ago
Please point the download button on the hello.firefox.com to the following URL and *not* download.mozilla.org:

https://www.mozilla.org/firefox/new/?scene=2&utm_source=hello.firefox.com&utm_medium=referral&utm_campaign=non-webrtc-browser#download-fx

This is better for three reasons:

1) It is a one-click download and no double clicks as mentioned above.

2) It provides download/install instructions

3) It also provides us with information on how many users take this flow and how successful they are

This bug is a duplicate of bug 1149793 that I just closed.

sescalante: Let me know when there is a code change or somewhere for me to test the updated URL.

Thanks!
Flags: needinfo?(sescalante)
(Assignee)

Comment 9

3 years ago
I can get this progressed.

Chris, for an initial test, would something on a development server be fine?
Assignee: nobody → standard8
Flags: needinfo?(sescalante) → needinfo?(chrismore.bugzilla)

Comment 10

3 years ago
(In reply to Mark Banner (:standard8) from comment #9)
> I can get this progressed.
> 
> Chris, for an initial test, would something on a development server be fine?

Sure, that works. This URL mentioned in comment 8 is exactly how we link other Mozilla websites to direct downloads and prevent the double button click issue mentioned above. Thanks!
Flags: needinfo?(chrismore.bugzilla)

Comment 11

3 years ago
Another benefit of comment 8 is that you don't need to get fancy with UA sniffing to generate a download.mozilla.org link because all of that logic exists on /firefox/new/. The /firefox/new/ page is also responsive and will provide buttons to the Google Play store and and Apple App Store (when iOS is out) automatically by UA sniffing. You won't have to create any additional logic and can just reply on the /firefox/new/ page to give the person the correct OS, language, and build without any extra work. Just make sure the locale is not in the URL as the site automatically detects locale too.
(Assignee)

Comment 12

3 years ago
Thanks Chris. Can you try this link please:

https://loop-webapp-dev.stage.mozaws.net/TEvLAFufVDA

That has the updated URL on the unsupported browser page (just don't expect anyone on the other end of that conversation ;-) ).

If that is fine, then its easy to roll out. I want to do a couple of cosmetic changes to the variable names, but that's a quick patch.
Flags: needinfo?(chrismore.bugzilla)

Comment 13

3 years ago
(In reply to Mark Banner (:standard8) from comment #12)
> Thanks Chris. Can you try this link please:
> 
> https://loop-webapp-dev.stage.mozaws.net/TEvLAFufVDA
> 
> That has the updated URL on the unsupported browser page (just don't expect
> anyone on the other end of that conversation ;-) ).
> 
> If that is fine, then its easy to roll out. I want to do a couple of
> cosmetic changes to the variable names, but that's a quick patch.

Hmmm. It works in Chrome and Firefox, but that's not all that helpful for an unsupported browser message. The auto download is acting funky on Safari and I need to also test IE. Investigating now.
Flags: needinfo?(chrismore.bugzilla)

Comment 14

3 years ago
Ok, I found the problem and it is Safari and how we are matching the URL. I need to file a bug to make this work for safari or we just get rid of the UTM parameters for now.

For now, just use this URL for the button and we can update it later:

https://www.mozilla.org/firefox/new/?scene=2#download-fx

Let me know when it is ready and I will test it out again.

Comment 15

3 years ago
Here's the bug I just filed on why adding the UTM parameters when using scene=2 doesn't work: bug 1150131
(Assignee)

Comment 16

3 years ago
I've updated the url to the reduced version.
Flags: needinfo?(chrismore.bugzilla)

Comment 17

3 years ago
(In reply to Mark Banner (:standard8) from comment #16)
> I've updated the url to the reduced version.

Mark: bug 1150131 is now resolved and thus we can use the URL from comment 8 now. Sorry for the back and forth and didn't expect the other bug to be resolved so quickly to allow the UTM parameters to work with the auto download link. Let me know when the comment 8 is up to test.
Flags: needinfo?(chrismore.bugzilla) → needinfo?(standard8)
(Assignee)

Comment 18

3 years ago
(In reply to Chris More [:cmore] from comment #17)
> (In reply to Mark Banner (:standard8) from comment #16)
> > I've updated the url to the reduced version.
> 
> Mark: bug 1150131 is now resolved and thus we can use the URL from comment 8
> now. Sorry for the back and forth and didn't expect the other bug to be
> resolved so quickly to allow the UTM parameters to work with the auto
> download link. Let me know when the comment 8 is up to test.

No problem, dev server is updated.
Flags: needinfo?(standard8) → needinfo?(chrismore.bugzilla)

Comment 19

3 years ago
I just tested Safari and it is working.

I just went to https://loop-webapp-dev.stage.mozaws.net/TEvLAFufVDA on Safari and the download button pointed to https://www.mozilla.org/en-US/firefox/new/?scene=2&utm_source=hello.firefox.com&utm_medium=referral&utm_campaign=non-webrtc-browser and clicking that button took me to the second scene of the download page and the download started automatically.

Going to test IE.
Flags: needinfo?(chrismore.bugzilla)

Comment 20

3 years ago
Tested IE with the same links in comment 19 and it also automatically downloads Firefox.

r+ from me.
(Assignee)

Comment 21

3 years ago
Created attachment 8589888 [details] [diff] [review]
For Loop standalone rename the brand website url to download firefox url and update the default.

This updates the defaults that we use for development, and provides a better naming of variables that we're using. I'll deal with requesting the actual config changes for the next deploys.
Attachment #8589888 - Flags: review?(dmose)
Comment on attachment 8589888 [details] [diff] [review]
For Loop standalone rename the brand website url to download firefox url and update the default.

Review of attachment 8589888 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good; r=dmose
Attachment #8589888 - Flags: review?(dmose) → review+
(Assignee)

Comment 23

3 years ago
Landed so this can start filtering through our repositories. I'll comment again when this gets out to production (it'll be marked as fixed before then), eta for production is sometime next week).

https://hg.mozilla.org/integration/fx-team/rev/58d88105ed8e
Iteration: --- → 40.1 - 13 Apr
Points: --- → 1
Target Milestone: --- → mozilla40
https://hg.mozilla.org/mozilla-central/rev/58d88105ed8e
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
(Assignee)

Comment 25

3 years ago
The config has been updated on the dev server now the patch has landed. It should roll out to production next week.

Comment 26

2 years ago
Verified this fix on various browsers, across platforms, as it follows:
Chrome version 43.0.2357.132 m, under Win 7 64-bit and Mac OS X 10.10.4: with WebRTC Block addon, by clicking the "Get Firefox" button, Firefox download starts directly. Same results encountered with Chrome Version 40.0.2214.93 on Ubuntu 14.04 32-bit, Microsoft Edge 20.10162.0.0 on Windows 10 64-bit, Safari version 5.1.7 (7534.57.2) and IE 11 on Windows 7 64-bit.

But, with Safari 9.0 under Mac OS X 10.10.4 I get http://i.imgur.com/MnWuHzu.png page; after clicking on Step 2 - Download and Install Firefox, the landing page is https://www.mozilla.org/en-US/firefox/new/ and another click on 'Free Download' button is needed in order for download to start. Mark, could you please give me an input here? Thanks in advance.
Flags: needinfo?(standard8)
(Assignee)

Comment 27

2 years ago
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #26)
> Verified this fix on various browsers, across platforms, as it follows:
> Chrome version 43.0.2357.132 m, under Win 7 64-bit and Mac OS X 10.10.4:
> with WebRTC Block addon, by clicking the "Get Firefox" button, Firefox
> download starts directly. Same results encountered with Chrome Version
> 40.0.2214.93 on Ubuntu 14.04 32-bit, Microsoft Edge 20.10162.0.0 on Windows
> 10 64-bit, Safari version 5.1.7 (7534.57.2) and IE 11 on Windows 7 64-bit.
> 
> But, with Safari 9.0 under Mac OS X 10.10.4 I get
> http://i.imgur.com/MnWuHzu.png page; after clicking on Step 2 - Download and
> Install Firefox, the landing page is
> https://www.mozilla.org/en-US/firefox/new/ and another click on 'Free
> Download' button is needed in order for download to start. Mark, could you
> please give me an input here? Thanks in advance.

I suspect Chris is a better person to answer that question.
Flags: needinfo?(standard8) → needinfo?(chrismore.bugzilla)

Comment 28

2 years ago
Where can I test out the auto download not working with safari? URL? Thanks
Flags: needinfo?(chrismore.bugzilla)
(Reporter)

Comment 29

2 years ago
(In reply to Chris More [:cmore] from comment #28)
> Where can I test out the auto download not working with safari? URL? Thanks

You can try with any Hello URL such as https://hello.firefox.com/B65J8tNT99w#UzBs3DNRPIPHN7FcgEYe5Q

Comment 30

2 years ago
(In reply to Romain Testard [:RT] from comment #29)
> (In reply to Chris More [:cmore] from comment #28)
> > Where can I test out the auto download not working with safari? URL? Thanks
> 
> You can try with any Hello URL such as
> https://hello.firefox.com/B65J8tNT99w#UzBs3DNRPIPHN7FcgEYe5Q

I just tried that link in Safari, it went to the second scene, and the download started automatically. 

Looks like it works for me.

:standard8: can you test or do you have a URL that doesn't work for you that I can test myself?
(In reply to Mark Banner (:standard8) (afk until 20th July) from comment #27)
> (In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #26)
> > Verified this fix on various browsers, across platforms, as it follows:
> > Chrome version 43.0.2357.132 m, under Win 7 64-bit and Mac OS X 10.10.4:
> > with WebRTC Block addon, by clicking the "Get Firefox" button, Firefox
> > download starts directly. Same results encountered with Chrome Version
> > 40.0.2214.93 on Ubuntu 14.04 32-bit, Microsoft Edge 20.10162.0.0 on Windows
> > 10 64-bit, Safari version 5.1.7 (7534.57.2) and IE 11 on Windows 7 64-bit.
> > 
> > But, with Safari 9.0 under Mac OS X 10.10.4 I get
> > http://i.imgur.com/MnWuHzu.png page; after clicking on Step 2 - Download and
> > Install Firefox, the landing page is
> > https://www.mozilla.org/en-US/firefox/new/ and another click on 'Free
> > Download' button is needed in order for download to start. Mark, could you
> > please give me an input here? Thanks in advance.
> 
> I suspect Chris is a better person to answer that question.

Mark, that variation was part of our first A/B test and from the Optimizely code it appears to be pointing to the second scene, so I'm not sure why it wasn't working properly. This test has since been shut off due to these variations not outperforming the original. Any questions, let me know.

Comment 32

2 years ago
I confirm that I can no longer reproduce this issue using Safari under Mac OS X 10.10.4 - the download starts correctly. Marking accordingly based on this result, comment 26 and comment 30.
Status: RESOLVED → VERIFIED
status-firefox40: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.