TSan: data race dom/storage/DOMStorageCache.cpp:447 GetItem

RESOLVED DUPLICATE of bug 1136857

Status

()

RESOLVED DUPLICATE of bug 1136857
4 years ago
3 years ago

People

(Reporter: froydnj, Assigned: mayhemer)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tsan])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8569441 [details]
storage-mloaded-race.txt

The attached logfile shows a thread/data race detected by TSan (ThreadSanitizer).

* Specific information about this bug

This race looks like domStorageCache::mLoaded is being modified under a lock, but being read outside of it.

* General information about TSan, data races, etc.

Typically, races reported by TSan are not false positives, but it is possible that the race is benign. Even in this case though, we should try to come up with a fix unless this would cause unacceptable performance issues. Also note that seemingly benign races can possibly be harmful (also depending on the compiler and the architecture) [1][2].

If the bug cannot be fixed, then this bug should be used to either make a compile-time annotation for blacklisting or add an entry to the runtime blacklist.

[1] http://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
[2] _How to miscompile programs with "benign" data races_: https://www.usenix.org/legacy/events/hotpar11/tech/final_files/Boehm.pdf
(Assignee)

Updated

4 years ago
Assignee: nobody → honzab.moz
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136857
You need to log in before you can comment on or make changes to this bug.