OOP and e10s Shumway extension is broken on Mac OSX 10.9.5

RESOLVED FIXED

Status

Firefox Graveyard
Shumway
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: yury, Unassigned)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Dependency tree / graph

Details

(Reporter)

Description

3 years ago
STR:
1. Install Shumway extension from http://www.areweflashyet.com/shumway/extension/firefox/shumway.xpi
2a. Select e10s
2b. Set dom.mozBrowserFramesEnabled boolean to `true`
3. http://www.areweflashyet.com/shumway/examples/external/externalinterface/external_interface_avm2.html

The first bad revision is:
changeset:   230178:8c11efebc455
user:        André Reinald <areinald@mozilla.com>
date:        Sat Feb 21 13:06:34 2015 +0100
summary:     Bug 1083344 - Tighten rules for Mac OS content process sandbox - "rules part". r=smichaud
(Reporter)

Comment 1

3 years ago
re: STR, before step 3 Firefox must be restarted.


Andre, do you have ideas why it's happening on 10.9.5 but not on 10.10?
Blocks: 1083344
Flags: needinfo?(areinald)

Comment 2

3 years ago
It's likely the extension changes what's being done by the content process, which is now sandboxed. 10.9 and 10.10 don't do things exactly the same way, but it's reasonably similar to factor out in the same set of rules.

I'd need relevant parts of /var/log/system.log when you do step 3, especially lines containing "plugin-container" or "sandbox".
Flags: needinfo?(areinald)
Blocks: 1037580

Comment 3

3 years ago
(In reply to Yury Delendik (:yury) from comment #1)
> re: STR, before step 3 Firefox must be restarted.
> 
> Andre, do you have ideas why it's happening on 10.9.5 but not on 10.10?

Yury, it's my turn to ask for info, as per comment 2.
Can you reproduce on a current nightly after setting security.sandbox.content.level to 1 and restarting?
If it reproduces, then please attach the relevant portion of the /var/log/system.log

If it doesn't, then I believe we should close this bug.
Flags: needinfo?(ydelendik)
(Reporter)

Comment 4

3 years ago
(In reply to André Reinald from comment #3)
> Can you reproduce on a current nightly after setting
> security.sandbox.content.level to 1 and restarting?
> If it reproduces, then please attach the relevant portion of the
> /var/log/system.log
> 
> If it doesn't, then I believe we should close this bug.

Sorry. Updated to OSX 10.10.
Flags: needinfo?(ydelendik)

Comment 5

3 years ago
Tested myself, STRs don't work any longer in 10.9.5 with sandbox enabled since last changes from bug 1083344. Closing.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.