Closed Bug 1137060 Opened 5 years ago Closed 5 years ago

Mac Xulrunner build broken by bug 1123990

Categories

(Release Engineering :: General, defect, blocker)

x86
macOS
defect
Not set
blocker

Tracking

(tracking-b2g:backlog, firefox36 unaffected, firefox37 fixed, firefox38+ fixed, firefox39 fixed)

RESOLVED FIXED
tracking-b2g backlog
Tracking Status
firefox36 --- unaffected
firefox37 --- fixed
firefox38 + fixed
firefox39 --- fixed

People

(Reporter: philor, Assigned: mshal)

References

Details

Attachments

(1 file)

/me casually leans against the goalpost, and shoves it back another 20 yards

The Xulrunner build is a funny thing: we only do them as nightlies, only on mozilla-central and mozilla-aurora, so you can't run them on try and so they are hidden by default. However, they are a release deliverable, so breaking them is a blocker.

http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/2015/02/2015-02-19-07-07-49-mozilla-central/mozilla-central-macosx64-xulrunner-nightly-bm82-build1-build2.txt.gz

cd ../../dist && (cd universal/xulrunner/XUL.framework/Contents/Resources && /builds/slave/m-cen-osx64-xr-ntly-0000000000/build/obj-firefox/i386/_virtualenv/bin/python /builds/slave/m-cen-osx64-xr-ntly-0000000000/build/config/createprecomplete.py) && gnutar -c --owner=0 --group=0 --numeric-owner --mode=go-w --exclude=.mkdir.done -f - -C universal/xulrunner XUL.framework | bzip2 -vf > xulrunner-38.0a1.en-US.mac.tar.bz2
/bin/sh: line 0: cd: universal/xulrunner/XUL.framework/Contents/Resources: No such file or directory
make[3]: *** [make-package-internal] Error 1
[Tracking Requested - why for this release]:

I'm told the sdk is a release deliverable, and this build is how we build it.
This seems to fix 'make package' when I build xulrunner locally on OSX, though as philor said I can't test on try. I did land this on ash and trigger nightlies, which appear to be working so far. I'll wait until they're all green before landing.
Assignee: nobody → mshal
Attachment #8570044 - Flags: review?(mh+mozilla)
I filed bug 1137382 as a follow-up as well.
Comment on attachment 8570044 [details] [diff] [review]
0001-Bug-1137060-Set-_RESPATH-for-OSX-xulrunner.patch

Review of attachment 8570044 [details] [diff] [review]:
-----------------------------------------------------------------

Heh, so we haven't made the signature changes to xulrunner?
Attachment #8570044 - Flags: review?(mh+mozilla) → review+
(In reply to Mike Hommey [:glandium] from comment #4)
> Comment on attachment 8570044 [details] [diff] [review]
> 0001-Bug-1137060-Set-_RESPATH-for-OSX-xulrunner.patch
> 
> Review of attachment 8570044 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Heh, so we haven't made the signature changes to xulrunner?

Not to B2G Desktop either, see bug 1101331 :)
But it doesn't seem bug 1123990 broke it though?
https://hg.mozilla.org/mozilla-central/rev/f15a73356ebd
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1141508
This needs to get backported to mozilla-beta before 37.0 ships, otherwise we won't be able to provide an SDK for add-on developers.
tracking-b2g: --- → ?
Flags: needinfo?(mshal)
Comment on attachment 8570044 [details] [diff] [review]
0001-Bug-1137060-Set-_RESPATH-for-OSX-xulrunner.patch

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: Without this, SDK builds fail on OSX
[Describe test coverage new/current, TreeHerder]: OSX Xr builds are green on m-c with this patch, but failing on m-a and m-b.
[Risks and why]: Could potentially break other builds that aren't tested properly on try/m-c, though none are known at this time.
[String/UUID change made/needed]: none
Flags: needinfo?(mshal)
Attachment #8570044 - Flags: approval-mozilla-beta?
Attachment #8570044 - Flags: approval-mozilla-aurora?
Comment on attachment 8570044 [details] [diff] [review]
0001-Bug-1137060-Set-_RESPATH-for-OSX-xulrunner.patch

Let's take this in Beta 6 so that we have at least some time to respond to any fallout. Beta+ Aurora+
Attachment #8570044 - Flags: approval-mozilla-beta?
Attachment #8570044 - Flags: approval-mozilla-beta+
Attachment #8570044 - Flags: approval-mozilla-aurora?
Attachment #8570044 - Flags: approval-mozilla-aurora+
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.