Sites with background image flickers/flashes when going back to tab after 2 minutes.

RESOLVED DUPLICATE of bug 1122643

Status

()

RESOLVED DUPLICATE of bug 1122643
4 years ago
3 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

36 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

When viewing websites with background images, such as twitter.com or my own website at www.markheadrick.com and I change to another tab for 2 minutes (this amount of time is repeatable anyway) I get a flicker of a black background before the page is fully drawn.  If I have multiple tabs with the same background image, only the first tab will show the flicker. It's like it's loosing the image in memory or something.  It has done this with Firefox in Safe Mode and with a new, clean profile. It has also done this with Hardware Acceleration off.

Windows 7 Pro 64bit w/ NVidia 550ti and 314.22 drivers.  Newer drivers are more problematic which is why I have stayed with these. 

Again, only pages with background images seem to show this flicker.  Did not happen with Firefox 35 on my system. 




Actual results:

Page flickers/flashes with a black background before showing properly.


Expected results:

Display tab same as if quickly going between them.
(Reporter)

Comment 1

4 years ago
Might be related to this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1137058
(Reporter)

Comment 2

4 years ago
Others have reported similar symptoms: http://forums.mozillazine.org/viewtopic.php?f=38&t=2916473

Comment 3

4 years ago
I have the same experience since upgrading to Firefox v36. It is also present for me when going back to previous pages as well as swapping tabs. I am running Win7 Ult with an NVidia GTX560 (driver 347.52). The visual was not present in previous builds of Firefox nor is it happening with other browsers.
(Reporter)

Comment 4

4 years ago
Thought I'd include a screenshot of what I see at my website for a split second after I go back to the tab: http://www.markheadrick.com/images/screenshots/ff36-background-image-flicker-mywebsite.jpg

Comment 5

4 years ago
Could this be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1135623?
(Reporter)

Comment 6

4 years ago
Maybe but my symptoms are present with Hardware Acceleration on or off. I always see the images properly, I just get this split-second flicker with <BODY> background images only when I switch back to the tab after a couple minutes.  On my website http://www.markheadrick.com I see the flicker on the right portion, a <BODY> background image; however, I do not on the menu to the left which is a DIV background image and the menu has z-index of 3.

The same graphical system could be responsible for both, however. I don't know. I am contemplating going back to 35.0.1 cause it's just annoying. I use twitter a lot and the background image flickers as well.
(Reporter)

Comment 7

4 years ago
After someone at Mozillazine mentioned, I downloaded and tried 37Beta2 and it does not have this behavior. Installed it in a separate folder and using its own profile.  So, looks like version 37 may correct this so far.
This is a dupe of bug 1113855.

However...

(In reply to MarkRH from comment #7)
> After someone at Mozillazine mentioned, I downloaded and tried 37Beta2 and
> it does not have this behavior. Installed it in a separate folder and using
> its own profile.  So, looks like version 37 may correct this so far.

That's very interesting to me! Bug 1113855 is not fixed in 37, but that release includes changes to image decoding that improve performance in some situations. It may be that the issue has just become less visible because of those performance improvements.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1113855
Hmm, OK. I thought it was odd that this improved in 37.

After reading through that MozillaZine thread, I'm pretty sure this is actually bug 1122643. It must affect Windows too.

Re-duping against bug 1122643.
Duplicate of bug: 1122643

Comment 10

4 years ago
I believe the issue is improved in 37 with bug 1079627 patches
You need to log in before you can comment on or make changes to this bug.