Closed Bug 1137101 Opened 8 years ago Closed 8 years ago

Refactor Response/Notification sent from nfcd

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox39 fixed)

RESOLVED FIXED
2.2 S12 (15may)
Tracking Status
firefox39 --- fixed

People

(Reporter: allstars.chh, Assigned: allstars.chh)

References

Details

(Whiteboard: [p=1])

Attachments

(2 files, 1 obsolete file)

I'd like to start refactoring the messages send from nfcd.
The problems for current message format are:

1. General Response is used to represent the response of WriteNDEF, makeReadOnly and Format requests. The problem is gecko needs to keep track of the last requests to know how to process this 'General Response' to Web application.

2. The type of the message is represented in 4 octets, and response code starts from 1000, and notification starts from 2000. I'd like to make it easier to make them both start from 0, and use the MSB to differentiate this message is response or notification.
Attached patch Patch. (obsolete) — Splinter Review
Comment on attachment 8569732 [details] [diff] [review]
Patch.

Review of attachment 8569732 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/nfc/gonk/NfcMessageHandler.cpp
@@ +125,5 @@
>    return result;
>  }
>  
>  bool
> +NfcMessageHandler::GeneralResponse(const int32_t response, const Parcel& aParcel, EventOptions& aOptions)

aResponse?
Attachment #8569732 - Flags: review?(dlee) → review+
Attachment #8569738 - Flags: review?(dlee) → review+
Attached patch Patch v2.Splinter Review
aResponse
Attachment #8569732 - Attachment is obsolete: true
Attachment #8569817 - Flags: review+
You need to log in before you can comment on or make changes to this bug.