Contacts tab doesn't appear after login with FxA

VERIFIED FIXED in Firefox 36

Status

Hello (Loop)
Client
P1
critical
Rank:
1
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: mikedeboer, Assigned: mikedeboer)

Tracking

unspecified
mozilla39
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify +

Firefox Tracking Flags

(firefox36+ verified, firefox37+ verified, firefox38+ verified, firefox39 verified, relnote-firefox 36+)

Details

Attachments

(2 attachments)

I noticed that the Contacts tab doesn't show and hide anymore after logging in and out with FxA. Only after a browser restart does the tab appear.

This is critical and greatly reduces the usability of Loop/ Hello, because there's no way to access the direct calling feature this way.
Flags: qe-verify+
Flags: firefox-backlog+
status-firefox36: ? → affected
I introduced this bug in my patch for bug : here `shouldComponentUpdate` was introduced for the TabView component in panel.jsx. It checks for changed properties, but only for the components' changed state, not its properties. The `buttonsHidden` property is the one we need to account for, because it determines whether the Contacts tab buttons is shown.

This unfortunately affects release, Fx 36, and IMHO warrants a point release.
Blocks: 1121210
Keywords: regression, regressionwindow-wanted
Created attachment 8569793 [details] [diff] [review]
Patch v1: fix for making the Loop contacts tab show and/ or hide when the user logs in or out of FxA
Attachment #8569793 - Flags: review?(standard8)
Priority: -- → P1
The thing I don't understand yet is why `browser/components/loop/test/mochitest/browser_toolbar.js` didn't catch this bug... I'm investigating this atm.
[Tracking Requested - why for this release]: This is impacting the FTU experience for Loop/ Hello direct calling. At the moment the contacts tab does _not_ show immediately after login with an Fx Account, only after a full browser restart.
tracking-firefox36: --- → ?
Can we write a browser chrome test that would have caught this?
Flags: needinfo?(mdeboer)
[Tracking Requested - why for this release]: see comment 4.
tracking-firefox37: --- → ?
tracking-firefox38: --- → ?
Flags: needinfo?(mdeboer)
Created attachment 8569960 [details] [diff] [review]
Patch 2: extend Loop toolbarbutton tests to check for correct panel states upon opening
Attachment #8569960 - Flags: review?(dmose)
(In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from comment #5)
> Can we write a browser chrome test that would have caught this?

Yes, I attached a test update patch just now. I was hinting at this in comment 3.
Attachment #8569960 - Flags: review?(standard8)
tracking-firefox36: ? → +
tracking-firefox37: ? → +
tracking-firefox38: ? → +

Updated

2 years ago
Rank: 1
Comment on attachment 8569793 [details] [diff] [review]
Patch v1: fix for making the Loop contacts tab show and/ or hide when the user logs in or out of FxA

Review of attachment 8569793 [details] [diff] [review]:
-----------------------------------------------------------------

Ok, I've given this a few runs through and it looks good.
Attachment #8569793 - Flags: review?(standard8) → review+
Attachment #8569960 - Flags: review?(standard8)
Attachment #8569960 - Flags: review?(dmose)
Attachment #8569960 - Flags: review+
Thanks Mark! Pushed to fx-team:

https://hg.mozilla.org/integration/fx-team/rev/52e496c8a9fa
https://hg.mozilla.org/integration/fx-team/rev/cb5051165c85
https://hg.mozilla.org/mozilla-central/rev/52e496c8a9fa
https://hg.mozilla.org/mozilla-central/rev/cb5051165c85
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox39: affected → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
 I know we are tracking this for release and there is probably going to be a 36.0.1.  Can you nominate it for uplift? Thanks!
Flags: needinfo?(mdeboer)
ni Sylvestre to review this bug for inclusion in 36.0.1, which gtb early this week.

Mike - It's preferable to get an uplift request by early Monday so that we can include the fix in 36.0.1 and 37 Beta 2.
Flags: needinfo?(sledru)
It is on my track list and we exchanged with Liz on this topic, no worries!
Flags: needinfo?(sledru)
Comment on attachment 8569793 [details] [diff] [review]
Patch v1: fix for making the Loop contacts tab show and/ or hide when the user logs in or out of FxA

Approval Request Comment
[Feature/regressing bug #]: bug 1121210
[User impact if declined]: After login with FxA, the user won't see the contacts tab inside the Loop panel _until_ he or she restarts the browser. This should happen instantly after login.
[Describe test coverage new/current, TreeHerder]: landed on m-c, adjusted unit tests to fail when this patch is not applied.
[Risks and why]: minor
[String/UUID change made/needed]: n/a
Flags: needinfo?(mdeboer)
Attachment #8569793 - Flags: approval-mozilla-release?
Attachment #8569793 - Flags: approval-mozilla-beta?
Attachment #8569793 - Flags: approval-mozilla-aurora?
Comment on attachment 8569960 [details] [diff] [review]
Patch 2: extend Loop toolbarbutton tests to check for correct panel states upon opening

See comment 15 for approval request. This patch contains the updated unit tests mentioned therein.
Attachment #8569960 - Flags: approval-mozilla-release?
Attachment #8569960 - Flags: approval-mozilla-beta?
Attachment #8569960 - Flags: approval-mozilla-aurora?
Attachment #8569960 - Flags: approval-mozilla-release?
Attachment #8569960 - Flags: approval-mozilla-release+
Attachment #8569960 - Flags: approval-mozilla-beta?
Attachment #8569960 - Flags: approval-mozilla-beta+
Attachment #8569960 - Flags: approval-mozilla-aurora?
Attachment #8569960 - Flags: approval-mozilla-aurora+
Sylvestre, you missed one ;)
Flags: needinfo?(sledru)
Comment on attachment 8569793 [details] [diff] [review]
Patch v1: fix for making the Loop contacts tab show and/ or hide when the user logs in or out of FxA

Oups, sorry
Flags: needinfo?(sledru)
Attachment #8569793 - Flags: approval-mozilla-release?
Attachment #8569793 - Flags: approval-mozilla-release+
Attachment #8569793 - Flags: approval-mozilla-beta?
Attachment #8569793 - Flags: approval-mozilla-beta+
Attachment #8569793 - Flags: approval-mozilla-aurora?
Attachment #8569793 - Flags: approval-mozilla-aurora+
Keywords: checkin-needed
checkin-needed is not needed for branch uplifts.
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/c1b3c8c553e9
https://hg.mozilla.org/releases/mozilla-aurora/rev/4b51b9e2c088
status-firefox38: affected → fixed
https://hg.mozilla.org/releases/mozilla-beta/rev/d5def3938b6e
https://hg.mozilla.org/releases/mozilla-beta/rev/824656d7ad0d
status-firefox37: affected → fixed
https://hg.mozilla.org/releases/mozilla-release/rev/7a4c981abfb6
https://hg.mozilla.org/releases/mozilla-release/rev/608bab8e4868
status-firefox36: affected → fixed
I was able to reproduce this issue on Firefox 39.0a1 (2015-02-26) using Windows 7 x64.
Verified fixed on Firefox 39.0a1 (2015-03-03), Firefox Dev Edition 38.0a2 (2015-03-03) and Firefox 37 Beta 2 (20150302192546) using Windows 7 x64, Ubuntu 13.10 x64 and Mac OS X 10.8.5.

I have noticed a potential issue: using a clean profile, after the first login with FxA, the Contacts tab appears with a delay of about 3 seconds.
 
Should I file another bug for this issues?
Status: RESOLVED → VERIFIED
status-firefox37: fixed → verified
status-firefox38: fixed → verified
status-firefox39: fixed → verified
Flags: needinfo?(mdeboer)
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #23)
> I have noticed a potential issue: using a clean profile, after the first
> login with FxA, the Contacts tab appears with a delay of about 3 seconds.
>  
> Should I file another bug for this issues?

Hi Vasilica, thanks for verifying this issue! It's expected that the contacts tab appears with a small delay. The FxA login process isn't the fastest, so no need to file an issue for this.
Flags: needinfo?(mdeboer)
Mike, would naïve users expect that delay? If not, maybe a new bug suggesting a spinner implementation would make sense… what do you think?
Blocks: 1139028
Hmm, you've got a point but that spinner would need to be on the toolbar button methinks.

Bugs are cheap: bug 1139028
Duplicate of this bug: 1138933
Verified fixed on Firefox 36.0.1 build 2 (20150305021524) using Windows 7 x64, Ubuntu 14.04 x32 and Mac OS X 10.9.5.
status-firefox36: fixed → verified
added to the release notes "36.0.1 - Hello contacts tab did not appear after login with Firefox Account (1137141)"
relnote-firefox: --- → 36+
You need to log in before you can comment on or make changes to this bug.