Closed Bug 1137156 Opened 10 years ago Closed 7 years ago

[Privacy Panel] [Remote protection] Special characters are not allowed in passphrase

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: genma, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

In, privacy panel, remote protection, special characters are not allowed in passphrase.


Actual results:

When the passphrase contains special characters, a message is displayed and the passphrase need to be corrected.


Expected results:

Special character must be allowed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
It was a UX decision to not include special characters. It is because the passphrase is sent over the SMS and the special characters "take up" too much space. Or something like that
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
This is not an acceptable argument when we talk about privacy !
We must have the ability to use all keyboard characters without restriction
marta,
(damn! sorry for the incomplete message).

Marta, could you provide a more complete answer on that? Special characters are widely advised to have secure passwords, your answer surprises me too.

Florent
Marta, can we have a more specific answer to explain this decision? It looks like a legitimate question regarding privacy/security...
Flags: needinfo?(marta)
So I think the issue is because the SMS messages have a special format and the password has maximum number of bytes.  IIRC, I think only allowing ASCII was to avoid the work of handling unicode passwords where 1 character > 1 byte and trying to detect when it won't fit into the SMS.  I could be wrong though.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
QA Whiteboard: [COM=Privacy Panel]
Yes that was exactly the issue, as Dave stated.
Flags: needinfo?(marta)
Stephanie, 
is that ok with you and can we close this bug?
Flags: needinfo?(stephouillon)
I understand this bug is a request for improvement, and that technically, if somebody is willing too, the support of unicode passwords could be implemented. Is that correct or do I miss something?
Flags: needinfo?(stephouillon)
Stephanie, in general it was a user-friendliness decision to avoid those in text messages, due to different size. But if there is a strong reason to implement it and someone is willing to do so - feel free and r? me on it.
Status: REOPENED → NEW
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 10 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.