Closed Bug 1137421 Opened 5 years ago Closed 5 years ago

Please sign the superfish hotfix xpi (v20150225.01)

Categories

(Release Engineering :: Release Requests, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Felipe, Assigned: rail)

References

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1110452 +++

To generate the XPI, do the following:

hg clone https://hg.mozilla.org/releases/firefox-hotfixes
cd firefox-hotfixes
HOTFIX=v20150225.01 make package

Then we need to sign the xpi generated at build/hotfix-v20150225.01.xpi
Assignee: nobody → rail
Attached file hotfix-v20150225.01-signed.xpi (obsolete) —
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Thanks Rail! Jorge, can you push this hotfix to staging?
Flags: needinfo?(jorge)
Minor hiccup: the maxVersion 39.* isn't supported on AMO yet. Can you set it to 38.*? It doesn't really make a different in terms of compatibility.
Flags: needinfo?(jorge) → needinfo?(felipc)
(In reply to Jorge Villalobos [:jorgev] from comment #3)
> Minor hiccup: the maxVersion 39.* isn't supported on AMO yet. Can you set it
> to 38.*? It doesn't really make a different in terms of compatibility.

I'm fine with this happening but can't make this change (it's landed already and I can't commit to firefox-hotfixes).
Changed maxVersion to 38.*:
https://hg.mozilla.org/releases/firefox-hotfixes/rev/4934d9ac1574

Rail, could you regenerate the xpi with the updated code and re-sign it?
Flags: needinfo?(felipc) → needinfo?(rail)
Status: RESOLVED → REOPENED
Flags: needinfo?(rail)
Resolution: FIXED → ---
Attachment #8570099 - Attachment is obsolete: true
Done
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
New xpi with better maxVersion available
Flags: needinfo?(jorge)
The add-on is staged now: https://addons-dev.allizom.org/en-US/firefox/addon/firefox-hotfix/

Please test.
Flags: needinfo?(jorge) → needinfo?(rail)
Jorge, please see https://bugzilla.mozilla.org/show_bug.cgi?id=1119899#c13

Can we move the conversation to a separate bug? This one was filed to sign the XPI and it's closed already.
Flags: needinfo?(rail)
You need to log in before you can comment on or make changes to this bug.