Closed Bug 1137535 Opened 6 years ago Closed 6 years ago

[RTL][Browser] Connection error message is not right-aligned in landscape mode

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: ychung, Unassigned)

References

Details

(Keywords: polish, Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(2 files)

Attached image InternetConnection.png
Description:
When the user opens a webpage added to the homescreen without internet connection, the message appears left-aligned when the device is set in landscape mode.

Repro Steps:
1) Update a Flame to 20150226010233.
2) Have Wi-Fi or data connected.
3) Go to any website on the browser. 
4) Select the ellipses button, and select "Add to home screen".
5) Select "Done".
6) Go to Settings > Browsing Privacy > Clear cookies and stored data > Clear.
7) Close the browser from Task manater.
8) Disconnect Wi-Fi or data connection.
9) Select the bookmark created from the homescreen.
10) Set the device in the landscape mode.

Actual:
The internet connection error message is left-aligned.

Expected:
The internet connection error message is right-aligned.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150226010233
Gaia: 7894b929f1b0394f3c997f72a6482bc7813e758d
Gecko: dd6353d61993
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: screenshot
This issue also reproduces on Flame 2.2.

Result: The internet connection error message is left-aligned.
 
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150226002503
Gaia: bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gecko: 363123044e61
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
This does not affect readability or functionality, and only happens in landscape mode, so putting as P3 at this point in the cycle
Priority: -- → P3
Keywords: polish
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15484/
Flags: in-moztrap+
Whiteboard: [3.0-Daily-Testing][systemsfe] → [3.0-Daily-Testing][systemsfe], MGSEI-RTL-3F
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact]MGSEI-RTL-3F
Whiteboard: [3.0-Daily-Testing][systemsfe], MGSEI-RTL-3F → [3.0-Daily-Testing][systemsfe]
Attached image AriesKK_v2.5.png
This issue can be reproduced on latest AriesKK v2.5 build by the same STR in comment 0.
Actual Result:The internet connection error message is left-aligned.
See attachment:AriesKK_v2.5.png.
Reproducing rate:10/10

Device:AriesKK v2.5 build
Build ID               20150812230643
Gaia Revision          52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gaia Date              2015-08-12 16:40:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150812.222959
Firmware Date          Wed Aug 12 22:30:07 UTC 2015
Bootloader             s1
Blocks: 1181921
QA Whiteboard: [QAnalyst-Triage+][rtl-impact]MGSEI-RTL-3F → [QAnalyst-Triage+][rtl-impact][MGSEI-RTL-3F][MGSEI-Triage+]
Cannot reproduce with latest master

Device: Flame
Build ID               20151009030234
Gaia Revision          1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gaia Date              2015-10-23 17:01:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d01dd42e654b8735d86f9e7c723cc869a3b56798
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150527.043015
Firmware Date          Wed May 27 04:30:24 EDT 2015
Bootloader             L1TC000118D0

May have been fixed by one of the rtl refacto for the system app.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.