Closed Bug 1137994 Opened 5 years ago Closed 4 years ago

Firefox doesn't terminate due to PR_Close blocking

Categories

(Firefox :: Untriaged, defect)

37 Branch
x86_64
Windows Server 2008
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: 2chaggrnet+bugzilla.mozilla, Unassigned)

References

Details

Attachments

(2 files)

782 bytes, text/plain
Details
999 bytes, text/plain
Details
Attached file stack.txt
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.11 Safari/537.36

Steps to reproduce:

I was browsing webpages by Firefox 37.0.0.5532 on Windows Server 2008 R2 SP3 64bit.


Actual results:

Suddenly it get unable to show new pages. After that, the Firefox process remains until Windows restarts even if the user closes all window. If the user tries to restart Firefox, it will only show error messages that it cannot open the user profile.

Process Explorer shows firefox.exe have a remaining thread. The stack trace, which is attached, shows PR_Close is blocking in kernel mode.


Expected results:

Firefox should show new pages and the process should terminate.
OS: Windows 7 → Windows Server 2008
Hardware: x86 → x86_64
Attached file stack2.txt
This is the stack frame of the thread taken by Process Hacker.
See Also: → 1105577
Try https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox to get a stack trace with symbols.

See also bug 1125686 comment 7, you may be having the same issue.
Flags: needinfo?(2chaggrnet+bugzilla.mozilla)
I don't see this problem on recent versions. It seems to be fixed.
Flags: needinfo?(2chaggrnet+bugzilla.mozilla)
OK, thanks for the update!
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.