Contact display name changes don't propagate to open conversations

RESOLVED FIXED in 1.6

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aleth, Assigned: aleth)

Tracking

trunk
x86
macOS

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
In particular the tab title and the conv top displayname don't change.
(Assignee)

Comment 1

4 years ago
Posted patch namechange.diff (obsolete) — Splinter Review
Free bonus: also fixes bug 955687.
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8571511 - Flags: review?(clokep)
(Assignee)

Comment 2

4 years ago
The 'buddy' in the conversation binding is the account buddy not the buddy, so I changed what we are observing to reflect that.
Attachment #8571511 - Attachment is obsolete: true
Attachment #8571511 - Flags: review?(clokep)
Attachment #8571516 - Flags: review?(clokep)
(Assignee)

Comment 3

4 years ago
(In reply to aleth [:aleth] from comment #2)
> The 'buddy' in the conversation binding is the account buddy not the buddy,
> so I changed what we are observing to reflect that.

To clarify: this refers to the change from v1 to v2.

Really we should probably be observing contact-display-name-changed instead of the accountbuddy, and make sure the displayName of the contact is used everywhere rather than that of the accountbuddy. But what's in this patch is consistent with the status quo of the conversation binding.
When do we expect to NOT have a tab, but have a conversation binding? (I.e. why add all the |if (tab)| checks?)
(In reply to Patrick Cloke [:clokep] from comment #4)
> When do we expect to NOT have a tab, but have a conversation binding? (I.e.
> why add all the |if (tab)| checks?)

The original reason for that was to make the conversation.xml binding self contained, so that add-ons could re-use it to build other alternative UIs.
Attachment #8571516 - Flags: review?(patrick+mozilla-bugzilla) → review+
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.6
(Assignee)

Updated

4 years ago
Duplicate of this bug: 955687
You need to log in before you can comment on or make changes to this bug.