hg in returning inconsistent not found http://hg.mozilla.org/users/mbanner_mozilla.com/fx-team-mobile/ (and probably other repos)

RESOLVED DUPLICATE of bug 1118267

Status

--
major
RESOLVED DUPLICATE of bug 1118267
4 years ago
3 years ago

People

(Reporter: standard8, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1102332 +++

I cloned the fx-team repo about a couple of weeks ago. Since then, I've been seeing inconsistent results - mainly that occasionally the repo isn't found, whereas most of the time it clones/updates successfully.

It looks like one of the webheads is out of sync - seems a bit similar to bug 1102332...
Running a verify now; will sync anything that's out of whack and report back.
I see only one user repo (gecko clone) out of sync, going back to 01/01/2015. Which repo are you seeing this on?
Flags: needinfo?(standard8)
(Reporter)

Comment 3

4 years ago
This one:

http://hg.mozilla.org/users/mbanner_mozilla.com/fx-team-mobile/

I've got an automated process that runs on an aws server once per hour and does an hg pull once per hour.

Very frequently its coming back with:

urllib2.HTTPError: HTTP Error 404: Not Found

Note: it could be attempting to pull from http or https, I'm not quite sure which.
Flags: needinfo?(standard8)
The repo is currently up to date on all webheads, but that doesn't mean it hasn't been out of date at some point. Any chance you have a timestamp for recent failures?
(Reporter)

Comment 5

4 years ago
The last one I got was 15:00 UTC today.
(Reporter)

Comment 6

4 years ago
More examples from the last 12 hours or so (all in UTC):

19:00
20:00
22:00
23:00
00:00
03:00

Comment 7

3 years ago
The 404 is likely due to a missing wsgi script for a particular user. Bug 1118267 tracked issued with hgweb8. I've also found some permissions issues likely preventing the cron job from auto repairing things. Things should be much happier now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118267
You need to log in before you can comment on or make changes to this bug.