Add version fields to built manifest.webapp files

RESOLVED FIXED in Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: stas, Assigned: gandalf)

Tracking

unspecified
2.2 S7 (6mar)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
In bug 1118946 we added moz.b2g.version.  Let's use it to add a "version" field to Gaia manifest.webapp files.  This will come in handy for langpacks (bug 1118946).
(Reporter)

Comment 1

4 years ago
moz.b2g.version is in "x.y" format.  Is that good enough for manifest's "version" or should we use "x.y.z"?
Created attachment 8572834 [details] [review]
[gaia] zbraniecki:1138450-add-app-version-to-manifest > mozilla-b2g:master
(Assignee)

Updated

4 years ago
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
(Assignee)

Comment 3

4 years ago
So, what I'm going to give you here is:

{
  "version": "3.0"
}

or

{
  "version": "2.2"
}

Can you confirm that this is what you expect for your App name API to work?
Flags: needinfo?(fabrice)
(Assignee)

Updated

4 years ago
Attachment #8572834 - Flags: review?(poirot.alex)
yes, that's fine.
Flags: needinfo?(fabrice)
(Assignee)

Comment 5

4 years ago
Comment on attachment 8572834 [details] [review]
[gaia] zbraniecki:1138450-add-app-version-to-manifest > mozilla-b2g:master

Ricky, would you have time to look at this? It's a small thing and would love to have it in time for the Gecko API Name patch.
Attachment #8572834 - Flags: review?(poirot.alex) → review?(ricky060709)
Comment on attachment 8572834 [details] [review]
[gaia] zbraniecki:1138450-add-app-version-to-manifest > mozilla-b2g:master

LGTM. r+
Attachment #8572834 - Flags: review?(ricky060709) → review+
(Assignee)

Comment 8

4 years ago
Comment on attachment 8572834 [details] [review]
[gaia] zbraniecki:1138450-add-app-version-to-manifest > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1118946
[User impact] if declined: firefox os localized with langpack will not have translated app names on the homescreen
[Testing completed]: local + gaia-try
[Risk to taking this patch] (and alternatives if risky): This patch only adds one field (app version) to app's manifest at buildtime.
[String changes made]: none
Attachment #8572834 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

4 years ago
Attachment #8572834 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(Assignee)

Comment 9

4 years ago
Created attachment 8575097 [details] [diff] [review]
patch against 2.2

Ricky, can you just check that my 2.2 patch looks as it should? 

The post-manifest.js file in 2.2 looks different from master, so I'd prefer to get your rubber stamp before I push. Thanks :)
Attachment #8575097 - Flags: feedback?(ricky060709)
Comment on attachment 8575097 [details] [diff] [review]
patch against 2.2

Review of attachment 8575097 [details] [diff] [review]:
-----------------------------------------------------------------

r+  again.
Attachment #8575097 - Flags: feedback?(ricky060709) → feedback+
(Assignee)

Comment 11

4 years ago
2.2: https://github.com/mozilla-b2g/gaia/commit/7fdef6943189b175c2b474b1656ef27a13d646fe
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S7 (6mar)
You need to log in before you can comment on or make changes to this bug.