[Search] When user saves a bookmark to homescreen with custom name rocketbar search will only show result when searching for original name

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: bzumwalt, Assigned: daleharvey)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(5 attachments)

Posted image Screenshot
Description:
When user adds a bookmark to the homescreen with a custom name, searching for custom name in rocketbar does not show bookmark as a result. Only searching for what the original name of the bookmark was will show result.

This occurs regardless of whether user has cleared browser history or not. This issue persists after device reboot.

Repro Steps:
1) Update a Flame to 20150302010223
2) Navigate to a website like bbc.com
3) Save page as homescreen bookmark with different name than original (e.g. "Google" instead of "BBC - Homepage")
4) Tap Rocketbar and search for "Google" (AR1)
5) Clear existing Rocketbar search and search for "BBC" (AR2)

Actual:
AR1: No local apps or icons appear in search results.
AR2: Locally saved bookmark with BBC icon named "Google" appears in search results

Expected:
Searching for custom named homescreen bookmark will show correct results.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150302010223
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: eea6188b9b05
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 3/3, 100%
See attached: screenshot
Issue DOES reproduce on Flame 2.1 & 2.2

No local apps or icons appear in Rocketbar search results while searching for custom named bookmark, but searching for original name causes bookmark to appear in search results.

Device: Flame 2.1
Build ID: 20150302001220
Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
Gecko: 9bf4c663241f
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2
Build ID: 20150302002504
Gaia: 77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gecko: 27ab8aa34201
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Unable to test feature in 2.0 as per https://bugzilla.mozilla.org/show_bug.cgi?id=1047680#c7
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This could frustrate the end user trying to find a page that they bookmarked so nominating this 2.2?
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Taking
Assignee: nobody → dale
Not blocking but common use-case. Lets fix this.
blocking-b2g: 2.2? → ---
Attachment #8573349 - Flags: review?(kgrandon)
Comment on attachment 8573349 [details] [review]
[gaia] daleharvey:1138631 > mozilla-b2g:master

Looks good to me, thanks!
Attachment #8573349 - Flags: review?(kgrandon) → review+
Gaia try is fully green, so landing.
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S8 (20mar)
(In reply to Gregor Wagner [:gwagner] from comment #4)
> Not blocking but common use-case. Lets fix this.

Gregor, are we going to land it to 2.2? I think it is a good user experience for end users when using search app with new result layout.
Keywords: verifyme
Posted video video
Hi Eric,
This problem is verified Fail on latest build of Flame 3.0, Could you please help with it? thanks!
See attachments: VerifyFail_video.MP4 & logcat_1001.txt
Rate: 5/5

Flame 3.0 build: (Fail)
Build ID               20150315160203
Gaia Revision          d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
Gaia Date              2015-03-13 15:58:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/af68c9c0e903
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.192711
Firmware Date          Sun Mar 15 19:27:22 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(echang)
Posted file logcat
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
(In reply to Shine from comment #10)
> Created attachment 8577949 [details]
> video
> 
> Hi Eric,
> This problem is verified Fail on latest build of Flame 3.0, Could you please
> help with it? thanks!
> See attachments: VerifyFail_video.MP4 & logcat_1001.txt
> Rate: 5/5
> 
> Flame 3.0 build: (Fail)
> Build ID               20150315160203
> Gaia Revision          d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
> Gaia Date              2015-03-13 15:58:35
> Gecko Revision        
> https://hg.mozilla.org/mozilla-central/rev/af68c9c0e903
> Gecko Version          39.0a1
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150315.192711
> Firmware Date          Sun Mar 15 19:27:22 EDT 2015
> Bootloader             L1TC000118D0

Reopen this bug according to comment 10
Status: RESOLVED → REOPENED
Flags: needinfo?(echang)
Resolution: FIXED → ---
After I retried, I found the bookmark name is case sensitive. So, if I saved bookmark name as "Google", I cannot use "google" as input in search app for this bookmark.
Dale, is this as design?
Flags: needinfo?(dale)
Good catch Hermes, its not by design, I think we should normalise the case of the name, but its a new feature, can we close this one and open a new bug for the normalisation?

Cheers
Flags: needinfo?(dale)
Filed the new bug 

https://bugzilla.mozilla.org/show_bug.cgi?id=1146876
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
(In reply to Dale Harvey (:daleharvey) from comment #14)
> Good catch Hermes, its not by design, I think we should normalise the case
> of the name, but its a new feature, can we close this one and open a new bug
> for the normalisation?
> 
> Cheers

Dale, thank you! I saw bug 1146876 is a 2.2 blocker which patch depends on the patch of this bug. 
Could you please also uplift this one to 2.2?
Comment on attachment 8573349 [details] [review]
[gaia] daleharvey:1138631 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New Development
[User impact] if declined: Cant search bookmarks by name
[Testing completed]: Automated tests added and baked in master
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8573349 - Flags: approval-gaia-v2.2?
NI myself for following verification
Flags: needinfo?(hcheng)
Could you approve this landing? It blocks another bug 1146876. Thanks!
Flags: needinfo?(hcheng) → needinfo?(bbajaj)
Flags: needinfo?(bbajaj)
Attachment #8573349 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been successfully verified on latest Nightly Flame v2.2&3.0.
See attachment: verified_v2.2&3.0.mp4
Reproduce rate: 0/5

STR:
1) Flash build.
2) Navigate to a website like "bbc.com" in Browser app.
3) Save page as homescreen bookmark with different name than original (e.g. "Google" instead of "BBC - Homepage").
4) Tap Rocketbar and search for "Google" (or "google").
**On the searching results list, the custom named homescreen bookmark ("Google") shows correctly as the 1st result. --OK 

5) Clear existing Rocketbar search and search for "bbc"(or "BBC")
**On the searching results list, the custom named homescreen bookmark ("Google") shows correctly as the 1st result as user expectation. 

------------------------------------------------------------------------
Device: Flame 2.2 build(Pass)
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Pass)
Build ID               20150406160205
Gaia Revision          834385f4c834238a4306bf87cc4be41615d91ff0
Gaia Date              2015-04-06 19:41:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a530b5c3b713
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.194015
Firmware Date          Mon Apr  6 19:40:27 EDT 2015
Bootloader             L1TC000118D0

Leaving "verifyme" for v2.1 uplift.
Also, verifying this issue is fixed on the latest Aries and Flame builds (2.5, 2.2).  Custom bookmark names are searchable and propagate correctly.  Also, because this is not a blocker in the 2.1 branch, I am changing the Status to Verified. 

Repro attempts 0/10 (per build) 

Environmental Variables:

Device: Aries 2.5
BuildID: 20150811152431
Gaia: 9a8880a95ee4a4aea7895d4e2bcab31bc49ea281
Gecko: d82b5a78686a4f6630128fa7b999e0e343a9ef06
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.5
Build ID: 20150811030209
Gaia: 9a8880a95ee4a4aea7895d4e2bcab31bc49ea281
Gecko: 8cba870a352c
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.2
Build ID: 20150811032503
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: 13c447ed929e
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [QAnalyst-Triage?][MGSEI-Triage+]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.