Closed Bug 1146876 Opened 5 years ago Closed 5 years ago

Search by bookmark name is case sensitive

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: daleharvey, Assigned: daleharvey)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

No description provided.
Assignee: nobody → dale
blocking-b2g: --- → 2.2+
Whiteboard: [systemsfe]
Attachment #8582401 - Flags: review?(kgrandon)
Comment on attachment 8582401 [details] [review]
[gaia] daleharvey:1146876 > mozilla-b2g:master

Looks good to me, thanks!
Attachment #8582401 - Flags: review?(kgrandon) → review+
Adding checkin-needed for autolander.
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
NI myself for following 2.2 and master verification (including bug 1138631).
Flags: needinfo?(hcheng)
Keywords: verifyme
Flags: needinfo?(hcheng)
Keywords: verifyme
sorry, double clicked...NI again.
Flags: needinfo?(hcheng)
Blocks: 1136831
Flags: needinfo?(hcheng)
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(dale)
Target Milestone: --- → 2.2 S9 (3apr)
Comment on attachment 8582401 [details] [review]
[gaia] daleharvey:1146876 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Incomplete new feature work
[User impact] if declined: Bad experience for searching custom named bookmarks
[Testing completed]: Automated tests added
[Risk to taking this patch] (and alternatives if risky): Little risk, one line patch with testing
[String changes made]:
Flags: needinfo?(dale)
Attachment #8582401 - Flags: approval-gaia-v2.2?
Blocks: 1138631
No longer blocks: 1136831
Attachment #8582401 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Needs rebasing for v2.2 uplift.
Flags: needinfo?(dale)
https://bugzilla.mozilla.org/show_bug.cgi?id=1138631 needs to be uplifted before this is, I just requested approval
Flags: needinfo?(dale)
Hi Hermes,

    Could you help to provide the detailed reproduce steps for me to verify this bug?

Thank you very much.
Flags: needinfo?(hcheng)
Shally,

You can use test case [1] to verify this bug.

[1] https://moztrap.mozilla.org/manage/cases/?filter-id=16134
Flags: needinfo?(hcheng)
This bug has been successfully verified on latest Nightly Flame v2.2&3.0.

See attachment: verified_v2.2&3.0.mp4.
Reproduce rate: 0/5

STR:
1.Open browser and visit any web site (ex: "http://yahoo.com/",or "bbc.com").
2.Tap "..."
3.Press "Add to home screen".
4.Change the name to a totally new name (ex: "Search Engine 1")
5.Go to Homescreen and then tap rocketbar.
6.Input the name at step 4 like "Search ENGINE 1" in rocketbar.
**In the search result list, the bookmark is the 1st result. --OK

----------------------------------------------------------------------------------
Device: Flame 2.2 build(Pass)
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Pass)
Build ID               20150406160205
Gaia Revision          834385f4c834238a4306bf87cc4be41615d91ff0
Gaia Date              2015-04-06 19:41:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a530b5c3b713
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.194015
Firmware Date          Mon Apr  6 19:40:27 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.