Closed Bug 1138738 Opened 5 years ago Closed 5 years ago
Pre-land strings for in-product tour pieces for Reading
Bug 1131112 is tracking the copy needed for in-product tour promotion of the ReadingList. That'll be landing on Aurora (or Beta?) eventually, so we'll want to pre-land strings. The majority of ReadingList strings already pre-landed in bug 1133673. There's a l10n extension of 2 weeks after the nightly->aurora 38 merge - ideally this should land before then.
Marco: FYI, we'll want to track this as part of the growth campaign too.
(In reply to Blair McBride [:Unfocused] (I don't read bugmail - needinfo? me!) from comment #1) > Marco: FYI, we'll want to track this as part of the growth campaign too. Thanks Blair. I've added it to the campaign priority list.
Product tour stings final approved in bug1131112comment6
Final copy document: https://bug1131112.bugzilla.mozilla.org/attachment.cgi?id=8564217
That's actually just a link to https://docs.google.com/a/mozilla.com/document/d/1S4fsT4-Pp0Uy1Opx6Vgz3lzpuouo5CAK6t7b7LNlPDo/edit
Assignee: nobody → bmcbride
(In reply to Justin Dolske [:Dolske] from comment #5) > That's actually just a link to > https://docs.google.com/a/mozilla.com/document/d/1S4fsT4- > Pp0Uy1Opx6Vgz3lzpuouo5CAK6t7b7LNlPDo/edit Are you commenting that this is not a sufficient format to deliver the strings? If not, let me know if there's a preferred method, or if this file should be changed at all. If you're making an observation, I added the doc link as an attachment to keep a single point of reference for the copy doc. FWIW this attachment was created before the Google docs were added to auto detect (bug1132963).
We were a little confused by that in a meeting last week, so I believe Justin was just wanting to confirm it was intentional. I've been working on this today, between that document and the mockup I think I have everything I need.
Status: NEW → ASSIGNED
I've intentionally stayed away from including step numbers in either the names of the strings, or the string values themselves - planning instead to let the code have complete control over that. This lets us change/add/remove/re-order the tour info panels in the future without needing to rename and re-localize all the strings.
Attachment #8574595 - Flags: review?(MattN+bmo)
I'm not sure the use of plurals here makes sense, it's also unclear which of the two numbers is actually the one that's used to switch between plural forms. In particular, I don't think that step 5 is a plural, and "of 5 steps" probably doesn't need them. It surely doesn't affect the grammar of Reader View etc.
Comment on attachment 8574595 [details] [diff] [review] Patch v1 Review of attachment 8574595 [details] [diff] [review]: ----------------------------------------------------------------- (In reply to Axel Hecht [:Pike] from comment #9) > I'm not sure the use of plurals here makes sense, it's also unclear which of > the two numbers is actually the one that's used to switch between plural > forms. I'm guessing it's the second number that's used for the plural form so that we don't show (1/1) if we're only showing one step. If that's the case, I'm not sure what we would replace the green button text with though… ::: browser/locales/en-US/chrome/browser/browser.properties @@ +682,5 @@ > +# Pre-landed strings for bug 1136570 > +readerView.promo.firstDetectedArticle.title = Read and save articles easily > +readerView.promo.firstDetectedArticle.body = Click the book to make articles easier to read and use the plus to save them for later. > +readingList.promo.firstUse.exitTourButton = Close > +readingList.promo.firstUse.tourDoneButton = Start Reading » Perhaps there should be localization notes for all of the "»" to explain that it's used as an indication that it's a button for the next step.
Attachment #8574595 - Flags: review?(MattN+bmo) → review+
Please don't use the plural forms here, it doesn't make any sense. > readingList.promo.firstUse.readingList.title = Reading List;Reading List (#1/#2) It should simply be "Reading List (#1/#2)". Eventually it can be translated as "#1 of #2", but it still doesn't need a plural form (there's no noun).
If we only have one or multiple steps, we shouldn't use the plural form. Languages like Polish are going to be asked for 4 versions, languages like Chinese for none. Maybe a format string to use is the right thing. Something like "pages suffix", being " (#1/#2)" in en-US, and being passed as "Reading List%S". We'd need to check the technical details.
Note that we have this kind of strings on mozilla.org for UI tours, so we have an idea of what localizations actually do in the wild. http://transvision.mozfr.org/string/?entity=mozilla_org/firefox/australis/fx36_tour.lang:aa66ce35&repo=mozilla_org
https://hg.mozilla.org/integration/fx-team/rev/33564c4e4ff6 Pre-landing more strings for the ReadingList project (I'm assuming we don't currently have blanket approval for Aurora).
Also: Thank you Pike & flod, that helped me :)
Dumb question based on UI tours on the web: going back is not supported? You can just move forward? Just to confirm that we're not missing any strings.
One more thought (sorry for the bug spam) after trying to localize the strings. "Sync" (two title strings): I assume this is a generic string, not the feature name? If that's the case, "Sign in to access your Reading List everywhere you use %S." is pretty confusing. Sign in to what?
(In reply to Francesco Lodolo [:flod] from comment #17) > going back is not supported? You > can just move forward? Just to confirm that we're not missing any strings. Correct. I think this is probably because the popups would be too crowded/noisy with a 3rd button added, and it likely wouldn't be used as much. (In reply to Francesco Lodolo [:flod] from comment #18) > "Sync" (two title strings): I assume this is a generic string, not the > feature name? > > If that's the case, "Sign in to access your Reading List everywhere you use > %S." is pretty confusing. Sign in to what? "sync" is messy, because it's both a commonly used word to describe the feature and is also the branded product name (which we use syncBrandShortName for). For the title, "Sync" is used to describe the feature. But for the body, it's referring to Sync as a product. It may make sense for some locales to re-order "Sign in to access your Reading List everywhere you use Sync." so that Sync (the product) is directly tied to "sign in". Do you think an additional localization note should be added for this?
Flags: needinfo?(bmcbride) → needinfo?(francesco.lodolo)
(In reply to Blair McBride [:Unfocused] (I don't read bugmail - needinfo? me!) from comment #19) > It may make sense for some locales to re-order "Sign in to access your > Reading List everywhere you use Sync." so that Sync (the product) is > directly tied to "sign in". > > Do you think an additional localization note should be added for this? A localization note would definitely be helpful to explain that "Sync" refers to the activity of syncing, not the feature name. Note that in this string %S is "Firefox", not "Sync", unless the existing localization comment is wrong.
Attachment #8575137 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.