[MSE] YouTube 1080p+ videos skipping frames/chunky playback

RESOLVED DUPLICATE of bug 1131638

Status

()

RESOLVED DUPLICATE of bug 1131638
4 years ago
4 years ago

People

(Reporter: rowbot, Assigned: mattwoodrow)

Tracking

(Blocks: 1 bug, {regression})

Trunk
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Playing a video on YouTube at 1080p or higher results in the video skipping frames despite the audio playing normally.  This began in the 2015-03-04 nightly.  Video resolutions of 720p and below all seem to play just fine.

Last good revision: ae1bfc458851
First bad revision: d08d7a1a55ba
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ae1bfc458851&tochange=d08d7a1a55ba

Adapter Description	NVIDIA GeForce GTX 660
Adapter Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM	2048
Device ID	0x11c0
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16492)
Driver Date	2-5-2015
Driver Version	9.18.13.4752
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	30693842
Vendor ID	0x10de
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
(Reporter)

Comment 1

4 years ago
I didn't really provide good STR in comment #0, so here they are:

1) Load a YouTube video
2) Set the quality to 1080p or higher
3) Allow the video to play for at least 15 seconds, as the skipped frames/chunky playback doesn't occur during the first 10-15 seconds.

This reproduces about 90% of the time for me, so you may need to refresh the page once or twice if you aren't able to reproduce the first time.  Switching back to 720p or lower will cause the video to play smoothly again.
(Assignee)

Updated

4 years ago
Assignee: nobody → matt.woodrow
Blocks: 778617, 1131638
Confirming, as I'm seeing this too, and in case it helps:

* https://www.youtube.com/watch?v=s0MDY9fl-IA is a good example URL
* Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
* System specs:
** Processor Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz 7.7 5.9 
** Memory (RAM) 32.0 GB 7.7 
** Graphics NVIDIA Quadro K600 6.8 
** Gaming graphics 17123 MB
** Total available graphics memory 6.8
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150306030229 CSet: 0189941a3fd5

I've been seeing this for the last couple of days too. Windows 7 / nVidia 660ti / 16 GB Ram / i5-2500k

Pick a video like:
- https://www.youtube.com/watch?v=gKyTrLRJPnM
- https://www.youtube.com/watch?v=T2kOj-GFN8k
Go fullscreen (makes it easier to see jankyness)
After a short period of time frames start to get dropped. Audio playback is perfectly smooth but video is jerky and rubbish to look at.
My findings are:

1. New profile, start Firefox.
2. Navigate to https://www.youtube.com/watch?v=gKyTrLRJPnM
3. Check that the HTML5 video is being played (I have not tested Flash)
4. If not set automagically, set the playback quality to 1080p
5. In the seek bar at the bottom there should be a yellow mark at 10 seconds which indicates that an advert will be displayed at that time
6. Wait until the video has gone passed the 10 second mark

Expected:
- When advert is shown, video playback remains smooth

Actual:
- When advert is shown, video playback becomes janky and stutters as if many frames are not being rendered. Even if you dismiss the advert, the playback remains poor.

Works:
- Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150303045145 CSet: e545f650c695 @ http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1425387105/

Broken:
- Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150303045547 CSet: 985070813323 @ http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1425387347/
Keywords: regression
Stephen: MSE triage team wants to know if this issue can be reproduced on FF 37 as well?
Flags: needinfo?(stephen.donner)
(In reply to Marcia Knous [:marcia - use ni] from comment #5)
> Stephen: MSE triage team wants to know if this issue can be reproduced on FF
> 37 as well?

I don't see the jankiness, but it'd be good for Steve England to weigh in, too.

I do see crashes, which I filed separately as bug 1141813.
Flags: needinfo?(stephen.donner)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20150309191715 CSet: 8065aad58fc2

Downloaded from http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/37.0b4/win32/en-US/ looks good to me; smooth playback and no blatant hitching, even when the advert appears.



With Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150310030235 CSet: 6686aacf006f the hitching has disappeared too, due to the back-out of bug 1131638 I guess.
Trevor - are you still seeing this problem since 1131638 relanded?
Flags: needinfo?(smokey101stair)
(Reporter)

Comment 9

4 years ago
I am not seeing this after Bug 1131638 relanded.  This bug can be closed.
Flags: needinfo?(smokey101stair)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131638
You need to log in before you can comment on or make changes to this bug.