If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Flame][Contacts]The contact is also deleted from ICE Contacts list when user deletes one phone number of the ICE Contact who has two phone numbers.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Shally Li(leave from Mozilla), Assigned: Adrián de la Rosa)

Tracking

({regression})

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Flame][v2.2&3.0][Contacts]The contact is also deleted from ICE Contacts list when user deletes the first phone number of ICE Contact which has two phone numbers in contact detail info.
Found time:16:36
Attch:ICE_contact.MP4 and logcat_1636.txt.

[2.Testing Steps]: 
1. Set ICE Contacts in Contacts app.
**Make sure that the ICE contacts have two phone numbers.  
2. Open one ICE Contact and tap Edit icon.
3. Delete the first phone number (Important), then tap "Update". 
**The prompt "All the numbers are deleted.This contact is removed form the ICE Contacts." will pop up,then you can tap "OK",then the first phone number is deleted.

[3.Expected Result]: 
3.Only the first phone number is deleted and the contact is not deleted from ICE Contacts list.

[4.Actual Result]: 
3.The contact is also deleted from ICE Contacts list.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150304002529
Gaia Revision          8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gaia Date              2015-03-03 15:01:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cb52b7cda5a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.042036
Firmware Date          Wed Mar  4 04:20:47 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150304010324
Gaia Revision          3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gaia Date              2015-03-03 21:58:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c5b90c003be8
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.041952
Firmware Date          Wed Mar  4 04:20:03 EST 2015
Bootloader             L1TC000118D0

Flame 2.1 build:
Build ID               20150304002212
Gaia Revision          7370d456a330882aa6c29cd5a6470b876038a622
Gaia Date              2015-03-03 19:44:19
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/81bbb1143b88
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.041213
Firmware Date          Wed Mar  4 04:12:24 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
14217

[8.Note]:
If you delete the second phone number of the ICE Contact,only the second number is deleted and the contact still exists in ICE Conacts list.
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.1S: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(Reporter)

Comment 1

3 years ago
Created attachment 8573152 [details]
logcat_1636.txt
(Reporter)

Comment 2

3 years ago
Created attachment 8573154 [details]
ICE_contact.MP4
(Reporter)

Comment 3

3 years ago
I can't repro this bug on 2.1S(512mb).

2.1S (512mb):
Build ID               20150304001605
Gaia Revision          a43d64ae01ef108aa4dcc971c770fecd8416a764
Gaia Date              2015-02-26 09:24:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/fab8e3ef191f
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
I remember this panel being introduced in 2.2. QA wanted to shoot a video of the behavior in 2.1.
Keywords: qawanted
QA Contact: bzumwalt
Youtube video showing behavior on Flame 2.1: http://youtu.be/nSbqhTA7yx4


Issue does not occur on Flame 2.1

First number is deleted, contact remains as ICE contact with no warning message.

Device: Flame 2.1
Build ID: 20150305001708
Gaia: 89db88a76ae8363cd7f8e7a07d35ae24058aec36
Gecko: b64b3a28d459
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted → regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I checked on 2.1 [1], this panel doesn't exist even if you delete the last phone number. It was decided in bug 1061420.

[Blocking Requested - why for this release]: New panel in 2.2 which doesn't work as a user would expect.

[1] Build ID               20150227002636
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0390c73a827b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20141120.194707
Firmware Date          Thu Nov 20 19:47:17 EST 2014
Bootloader             L1TC00011880
Blocks: 1061420
blocking-b2g: --- → 2.2?
triage: regression
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

3 years ago
Assignee: nobody → hola
Status: NEW → ASSIGNED

Comment 8

3 years ago
Created attachment 8575388 [details] [review]
[gaia] ADLR-es:1139812 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8575388 - Flags: review?(jmcf)

Comment 9

3 years ago
Comment on attachment 8575388 [details] [review]
[gaia] ADLR-es:1139812 > mozilla-b2g:master

more work is needed
Attachment #8575388 - Flags: review?(jmcf)
(Assignee)

Comment 10

3 years ago
Comment on attachment 8575388 [details] [review]
[gaia] ADLR-es:1139812 > mozilla-b2g:master

Both comments solved, asking r? again.

Thanks.
Attachment #8575388 - Flags: review?(jmcf)

Comment 11

3 years ago
Comment on attachment 8575388 [details] [review]
[gaia] ADLR-es:1139812 > mozilla-b2g:master

LGTM, but please take into account the comments I left on GH
Attachment #8575388 - Flags: review?(jmcf) → review+
(Assignee)

Comment 12

3 years ago
Patch updated according to comments.
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Comment 13

3 years ago
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/9fa6e19a288f71a4e3200a9eb1b3d7aeb92d00e3

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
status-b2g-master: affected → fixed
Keywords: verifyme
Target Milestone: --- → 2.2 S8 (20mar)
Hei Adrian, can you request for 2.2 approval?

Thanks!
Flags: needinfo?(hola)
(Assignee)

Comment 15

3 years ago
Comment on attachment 8575388 [details] [review]
[gaia] ADLR-es:1139812 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1061420 
[User impact] if declined: Confusing behavior when deleting a phone for a ICE contact.
[Testing completed]: Manual testing, integration test added.
[Risk to taking this patch] (and alternatives if risky): Low risk, small change.
[String changes made]: None.
Flags: needinfo?(hola)
Attachment #8575388 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8575388 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/9d09c08ffcc285ed443e29e16e30798e7fd6582d
status-b2g-v2.2: affected → fixed
Created attachment 8579164 [details]
Verify_video.MP4

This problem is verified pass on latest build of Flame 2.2 and Flame3.0. Whether you delete the first, second or third phone number, the contact will not be deleted from ICE Contacts list.
See attachment: Verify_video.MP4
Rate: 0/10

Flame 2.2 build: (Pass)
Build ID               20150317162504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/83251e534b33
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.195036
Firmware Date          Tue Mar 17 19:50:45 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: (Pass)
Build ID               20150317073344
Gaia Revision          738987bd80b0ddb4ccf853855388c2627e19dcc1
Gaia Date              2015-03-17 02:27:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/008b3f65a7e0
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.111450
Firmware Date          Tue Mar 17 11:15:00 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.