[STK] LAUNCH_BROWSER confirm message is not displayed if icon is self explanatory

RESOLVED DUPLICATE of bug 1140153

Status

defect
RESOLVED DUPLICATE of bug 1140153
4 years ago
4 years ago

People

(Reporter: anshulj, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

(Whiteboard: [caf priority: p2][CR 804219])

Reporter

Description

4 years ago
Observed:LAUNCH_BROWSER confirm message is not displayed if icon is self explanatory
Expected: Confirm message should still be displayed with just an icon if the icon is self explanatory.

The root cause of the issue is that showURL function in icc.js at [1] only checks for text to be available before displaying the confirm message. Adding a (icons != null) check fixes the issue.

[1] http://lxr.mozilla.org/gaia/source/apps/system/js/icc.js#530
Reporter

Updated

4 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Whiteboard: [CR 804219]
Whiteboard: [CR 804219] → [caf priority: p2][CR 804219]
NI fresla, to see if he can add that quick check.
Flags: needinfo?(frsela)

Updated

4 years ago

Updated

4 years ago
No longer blocks: CAF-v3.0-FL-metabug
Is this a cert blocker or does it block CAF testing?
Flags: needinfo?(anshulj)
Reporter

Comment 3

4 years ago
Wesley technically this breaks the spec so yes a cert blocker.
Flags: needinfo?(anshulj)
wesley, can you get this assigned?
blocking-b2g: 2.2? → 2.2+
Reporter

Comment 5

4 years ago
The fix for bug 1140153 also fixes this issue.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1140153
Flags: needinfo?(frsela)
No longer blocks: CAF-v2.2-metabug
No longer blocks: CAF-v2.2-metabug
No longer blocks: CAF-v2.2-metabug
You need to log in before you can comment on or make changes to this bug.