Closed Bug 1140329 Opened 5 years ago Closed 5 years ago

[Contacts]The contact's Birthday is not same as that in PC if it is a contact imported from oultlook account.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.2+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

RESOLVED FIXED
2.2 S8 (20mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: liuyong, Assigned: ferjm)

References

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(4 files)

Attached image Birthday.png
[1.Description]:
[Nexus 5 v2.2&v3.0][Flame v2.2][Contacts] Import a outlook contact from PC, its birthday will be changed, the Year and Month doesn't match with PC..
Found time:16:56
Attachment:logcat_1456.txt, Birthday.png

[2.Testing Steps]: 
PREREQUISITES:There is a contact(A) with birthday in outlook account.
1. Launch Contact.
2. Tap Settings->"Import Contacts", select Outlook.
3. login Outlook, import contact A to device.
4. Check the information about A.

[3.Expected Result]: 
4. The birthday should be the same as that in PC, the Year and Month doesn't match it on PC.

[4.Actual Result]: 
4. The birthday isn't the same as that in PC.

[5.Reproduction build]: 
N5_2.2:
Build ID               20150305002528
Gaia Revision          89af288bad6751248ff84504fa898206fee127fe
Gaia Date              2015-03-04 18:00:05
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6d8d294aa8f3
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150305.041802
Firmware Date          Thu Mar  5 04:18:17 EST 2015
Bootloader             HHZ12d

N5_3.0 build:
Build ID               20150305160202
Gaia Revision          7a91c16bfa348be8b25e09719178efa051512988
Gaia Date              2015-03-05 19:20:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0189941a3fd5
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150305.191827
Firmware Date          Thu Mar  5 19:18:43 EST 2015
Bootloader             HHZ12d

Flame 2.2:
Build ID               20150305002528
Gaia Revision          89af288bad6751248ff84504fa898206fee127fe
Gaia Date              2015-03-04 18:00:05
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6d8d294aa8f3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150305.094337
Firmware Date          Thu Mar  5 09:43:49 EST 2015
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free test

[8.Note]:
This issue  exists on Flame 2.2 and Nexus 5_3.0.
Attached file logcat_1656.txt
QA wanted to check 2.1 and if it does repro, 2.0.
Keywords: qawanted
Summary: [Nexus 5][Contacts]The contact's Birthday is not same as that in PC if it is a contact imported from oultlook account. → [Contacts]The contact's Birthday is not same as that in PC if it is a contact imported from oultlook account.
Whiteboard: v2.2-nexus-5-l → [2.2-nexus-5-l]
QA Contact: ychung
This issue also reproduces on Flame 2.1, v18D-1 base image (2.0), and v188-1 base image (2.0).

Result: The imported Outlook contacts are displayed with incorrect birthdays. 

Environmental Variables:
Device: Flame 2.1
BuildID: 20150305113112
Gaia: ea97a87048a4c1e2a479bbea1d75e0a182b2c4c9
Gecko: 871071010b5b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Hi Coler, Could you also try gmail, is that also happening? Thank you.
Flags: needinfo?(liuyong)
[Blocking Requested - why for this release]:

User data is altered, quite a serious issue, suggest to fix it.
blocking-b2g: --- → 2.2?
Flags: needinfo?(francisco)
Hi Eric,
   We have tried with Gmail account, this bug can't be repro with Gmail, the birthday date is same as it in PC. Hope this can help you. Thnaks!
Flags: needinfo?(liuyong) → needinfo?(echang)
Thanks a lot for your help.
Flags: needinfo?(echang)
I can confirm that dates for birthdays are totally wrong. No matter if it's from a PC, any import from Outlook (live), will provide a weird birthday date.
Flags: needinfo?(francisco)
Hi Fernando, can you take a look to this?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(ferjmoreno)
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
Attachment #8576626 - Flags: review?(francisco)
Attachment #8576626 - Flags: review?(francisco)
Attachment #8576626 - Flags: review?(francisco)
Comment on attachment 8576626 [details] [review]
[gaia] ferjm:bug1140329.contacts.bday > mozilla-b2g:master

LGTM.
Attachment #8576626 - Flags: review?(francisco) → review+
http://docs.taskcluster.net/tools/task-graph-inspector/#DtBeDwD5TAe-83Qw-_oNrQ

The pull request failed to pass integration tests. It could not be landed, please try again.
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#QYiES6IUTkSdn_UOSExGWg

The pull request failed to pass integration tests. It could not be landed, please try again.
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#jmKXLdVARn2KIFZ1W9JNYQ

The pull request failed to pass integration tests. It could not be landed, please try again.
Damn autolander...

https://github.com/mozilla-b2g/gaia/commit/9417a91b22d380809cec5f0285a51a8d6e34865b
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 on this when you get a chance.
Flags: needinfo?(ferjmoreno)
Target Milestone: --- → 2.2 S8 (20mar)
Comment on attachment 8576626 [details] [review]
[gaia] ferjm:bug1140329.contacts.bday > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Contacts import
[User impact] if declined: We display wrong information. Users could miss a birthday!
[Testing completed]: Manual testing.
[Risk to taking this patch] (and alternatives if risky): Very low risk. The change is quite isolated and only affects the live importer.
[String changes made]: None.
Flags: needinfo?(ferjmoreno)
Attachment #8576626 - Flags: approval-gaia-v2.2?
Attachment #8576626 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
When importing contacts from Outlook the year is dropped from the contacts birthday now.  The Month and Day are correctly imported and the years were valid if making a new contact but were not imported (1963 and 1986 were checked)

Environmental Variables:
Device: Flame 3.0
BuildID: 20150318055750
Gaia: b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gecko: 41a61514461e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
(In reply to Jayme Mercado [:JMercado] from comment #18)
> When importing contacts from Outlook the year is dropped from the contacts
> birthday now.  The Month and Day are correctly imported and the years were
> valid if making a new contact but were not imported (1963 and 1986 were
> checked)
> 
> Environmental Variables:
> Device: Flame 3.0
> BuildID: 20150318055750
> Gaia: b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
> Gecko: 41a61514461e
> Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
> Version: 39.0a1 (3.0) 
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Yes, that's all we can do now. Live doesn't expose the year anymore (or maybe it never did...)
See Also: → 1161975
Attached image verify.png
Per Comment 19
This issue is verified fixed on latest build of Flame 2.2 3.0,the STR is same as Comment 0.
Reproduce rate:0/5
See verify.png

Flame 2.2(Fixed):
Build ID               20150506002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3af6a0a79227
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.040209
Firmware Date          Wed May  6 04:02:20 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Fixed):
Build ID               20150506160205
Gaia Revision          426fe6450ab8da92bb473fef12ccb39c6c920dd0
Gaia Date              2015-05-06 08:40:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5593ac626826
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.193508
Firmware Date          Wed May  6 19:35:21 EDT 2015
Bootloader             L1TC000118D0
This issue also be verified fixed on latest build of Nexus5 2.2 3.0,the STR is same as Comment 0.
Reproduce rate:0/5

N5_2.2(Fixed)
Build ID               20150506002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3af6a0a79227
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150506.040123
Firmware Date          Wed May  6 04:01:41 EDT 2015
Bootloader             HHZ12f

Nexus_5 3.0(Fixed):
Build ID               20150506160205
Gaia Revision          426fe6450ab8da92bb473fef12ccb39c6c920dd0
Gaia Date              2015-05-06 08:40:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5593ac626826
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150506.192419
Firmware Date          Wed May  6 19:24:33 EDT 2015
Bootloader             HHZ12f
You need to log in before you can comment on or make changes to this bug.