Some birthdays are shown completely wrong in the address book

RESOLVED DUPLICATE of bug 1122571

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 1122571
3 years ago
3 years ago

People

(Reporter: Martin, Unassigned)

Tracking

31 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8573855 [details]
thunderbird_bug.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

I inserted a new birthday into a new entry. The date I entered was October 28 1977. (it doesn't matter if you fill in the date by hand or use the date-picker).


Actual results:

If I list the address book, the date "October 27 1977" is shown (see screenshot).


Expected results:

It should have been "October 28 1977". In the area where I can edit the birthday everything seems to be correct. I tried this several times on serveral computers (with the latest stable Thunderbird 31.5.0 - German translation).

The problem is really strage. I tested the entry with different years (the day always was "28" and the month "October").

Here are my results seen in the address book overview (tested years from 1970 to 2015):

10/28/1970 => shows 10/28/1970
10/28/1971 => shows 10/27/1971 - wrong!
10/28/1972 => shows 10/27/1972 - wrong!
10/28/1973 => shows 10/27/1973 - wrong!
10/28/1974 => shows 10/28/1974
10/28/1975 => shows 10/28/1975
10/28/1976 => shows 10/27/1976 - wrong!
10/28/1977 => shows 10/27/1977 - wrong!
10/28/1978 => shows 10/27/1978 - wrong!
10/28/1979 => shows 10/27/1979 - wrong!
10/28/1980 => shows 10/28/1980
10/28/1981 => shows 10/28/1981
10/28/1982 => shows 10/27/1982 - wrong!
10/28/1983 => shows 10/27/1983 - wrong!
10/28/1984 => shows 10/27/1984 - wrong!
10/28/1985 => shows 10/28/1985
10/28/1986 => shows 10/28/1986
10/28/1987 => shows 10/28/1987
10/28/1988 => shows 10/27/1988 - wrong!
10/28/1989 => shows 10/27/1989 - wrong!
10/28/1990 => shows 10/27/1990 - wrong!
10/28/1991 => shows 10/28/1991
10/28/1992 => shows 10/28/1992
10/28/1993 => shows 10/27/1993 - wrong!
10/28/1994 => shows 10/27/1994 - wrong!
10/28/1995 => shows 10/27/1995 - wrong!
10/28/1996 => shows 10/28/1996
             . . . 
10/28/2015 => shows 10/28/2015


I now tested the birthday with July 15 1978 - this is shown wrong, too. I'm pretty sure more dates are shown the wrong way.

Comment 1

3 years ago
Martin, vielen Dank! :)

Confirming exactly as described (both on TB 31.5.0 and Trunk, Win 8.1, local time DE 9:35).
After entering 28th Oct 1977 on the card ("28.10."+"1977"), the card preview immediately shows 27th Oct 1977 (27.10.1977). Unbelievable. Odd.

Looking at duplicate/related bugs, the internals of the date picker and the interaction with localized date formats seems to be quite tricky. Still, we ought to get it right and not mangle with user's data.

Comment 2

3 years ago
This most likely involves daylight savings time (Sommerzeit), dates are saved with time 00:00:00 and then wrongly calculated as 23:00:00 of previous day. JavaScript function Date.toLocaleDateString() gets it wrong, apparently even on other browsers like Chrome (per https://bugzilla.mozilla.org/show_bug.cgi?id=1139167#c1).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1122571
You need to log in before you can comment on or make changes to this bug.