Closed Bug 1140389 Opened 5 years ago Closed 5 years ago

test_SQLiteStore.js and test_ReadingList.js failing on Windows due to NS_ERROR_FILE_IS_LOCKED

Categories

(Firefox Graveyard :: Reading List, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(firefox38 fixed, firefox39 fixed)

RESOLVED FIXED
Firefox 39
Tracking Status
firefox38 --- fixed
firefox39 --- fixed

People

(Reporter: Unfocused, Assigned: adw)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

Saw these failing on Windows, but didn't want to make to hold up landing bug 1131362, since it's blocking pretty much all work.

Two tests are failing on my Windows box with:

 0:01.82 LOG: Thread-22 ERROR NS_ERROR_FILE_IS_LOCKED: Component returned failure code: 0x8052000e (NS_ERROR_FILE_IS_LOCKED) [nsIFile.remove]
removeDB@d:/mozilla/central/obj-i686-pc-mingw32/_tests/xpcshell/browser/components/readinglist/test/xpcshell/test_SQLiteStore.js:22:6
_execute_test@d:\mozilla\central\testing\xpcshell\head.js:557:15

This is a classic issue on Windows, so I wasn't overly concerned about it.
Flags: qe-verify-
Flags: firefox-backlog+
Depends on: 1131362
P2 because this is a new test for our feature.
Blocks: 1131362
No longer depends on: 1131362
Priority: -- → P2
Attached patch disable on Windows only for now (obsolete) — Splinter Review
Surely it's better to disable them on Windows only...  In the meantime I'll try to figure out what the problem is since this is news to me.
Attachment #8575469 - Flags: review?(bmcbride)
This should be the proper fix.  Try is green so far: https://treeherder.mozilla.org/#/jobs?repo=try&revision=bff1dae02a52
Assignee: nobody → adw
Attachment #8575469 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8575469 - Flags: review?(bmcbride)
Attachment #8575568 - Flags: review?(bmcbride)
Comment on attachment 8575568 [details] [diff] [review]
wait for the DB to close before trying to remove the file

Review of attachment 8575568 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/readinglist/test/xpcshell/test_ReadingList.js
@@ +22,5 @@
>    Assert.ok(gList);
>    gDBFile.append(gList._store.pathRelativeToProfileDir);
> +  do_register_cleanup(function* () {
> +    // Wait for the store to close its connection to the database.
> +    yield gList._store.destroy();

Isn't it safer for this to be calling gList.destroy()?
Attachment #8575568 - Flags: review?(bmcbride) → review+
Should this bug be prioritized as a P1 for the campaign release?
Flags: needinfo?(dolske)
(In reply to Marco Mucci [:MarcoM] from comment #5)
> Should this bug be prioritized as a P1 for the campaign release?

We discussed this during the triage meeting - we *really* want it, but can theoretically ship without. So P2.
Flags: needinfo?(dolske)
Comment addressed.

Of course the tree is closed.
Attachment #8575568 - Attachment is obsolete: true
Attachment #8576200 - Flags: review+
Iteration: --- → 39.2 - 23 Mar
https://hg.mozilla.org/integration/fx-team/rev/509ee098ee63
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/509ee098ee63
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 39
Blocks: 1132074
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.