Intermittent test-test-memory.js.testGC | Test timed out (after: the weakref returned the tempObj) and others after it

RESOLVED DUPLICATE of bug 1144193

Status

Add-on SDK
General
P1
normal
RESOLVED DUPLICATE of bug 1144193
3 years ago
3 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Did something get GCed out from under the test?

06:34:36     INFO -  TEST-INFO: jetpack-package/addon-sdk/source/test/test-test-memory.js | Loading test module
06:34:36     INFO -  TEST-INFO | executing 'jetpack-package/addon-sdk/source/test/test-test-memory.js.testGC'
06:34:36     INFO -  TEST-PASS | jetpack-package/addon-sdk/source/test/test-test-memory.js.testGC | the weakref returned the tempObj
06:34:53  WARNING -  TEST-UNEXPECTED-FAIL | jetpack-package/addon-sdk/source/test/test-test-memory.js.testGC | Test timed out (after: the weakref returned the tempObj)
06:34:54     INFO -  TEST-INFO | Traceback (most recent call last):
06:34:54     INFO -    File "resource://gre/modules/commonjs/sdk/timers.js", line 40, in notify
06:34:54     INFO -      callback.apply(null, args);
06:34:54     INFO -    File "resource://gre/modules/commonjs/sdk/deprecated/unit-test.js", line 490, in tiredOfWaiting
06:34:54     INFO -      self.console.testMessage(false, false, self.test.name,
06:34:54     INFO -    File "resource://gre/modules/commonjs/sdk/test/harness.js", line 543, in testMessage
06:34:54     INFO -      this.trace();
06:34:57     INFO -  TEST-PASS | jetpack-package/addon-sdk/source/test/test-test-memory.js.testGC | there is no argument
06:34:57     INFO -  TEST-PASS | jetpack-package/addon-sdk/source/test/test-test-memory.js.testGC | gc() returns a promise which eventually resolves
06:34:57     INFO -  TEST-PASS | jetpack-package/addon-sdk/source/test/test-test-memory.js.testGC | the weakref returned undefined

See the full log for more similar-looking failures.
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-macosx64/1425645394/fx-team_yosemite_test-mochitest-jetpack-bm106-tests1-macosx-build4.txt.gz
Comment hidden (Treeherder Robot)
Comment hidden (spam)
Please don't play in bugzilla
blocking-fx: ? → ---
status-b2g-v1.4: ? → ---
status-b2g-v2.0: ? → ---
status-b2g-v2.0M: ? → ---
status-b2g-v2.1: ? → ---
status-b2g-v2.1S: ? → ---
status-b2g-v2.2: ? → ---
status-firefox36: ? → ---
status-firefox37: ? → ---
status-firefox38: ? → ---
status-firefox39: ? → ---
status-firefox-esr31: ? → ---
status-firefox-esr38: ? → ---
tracking-b2g: ? → ---
tracking-e10s: ? → ---
tracking-firefox36: ? → ---
tracking-firefox37: ? → ---
tracking-firefox38: ? → ---
tracking-firefox39: ? → ---
tracking-firefox-esr31: ? → ---
tracking-firefox-esr38: ? → ---
relnote-firefox: ? → ---
relnote-b2g: ? → ---
Flags: sec-review?
Flags: needinfo?
Blocks: 1111478
Priority: -- → P1
Hardware: x86_64 → All
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1144193
You need to log in before you can comment on or make changes to this bug.