[RTL][Rocketbar] Search engine value selector blue triangle icon looks jagged

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: pcheng, Assigned: benfrancis)

Tracking

({regression})

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing] [systemsfe])

Attachments

(3 attachments)

Posted image screenshot.png
Description:
When searching via Rocketbar, there is a search engine dropdown within the divider line, and the blue triangle icon has rough edges instead of showing a smooth edged icon.

Prerequisite:
In RTL language

STR:
1) On Homescreen, tap on Rocketbar
2) Type some characters into serach field, and notice the blue colored search engine drop down list triangle icon

Expected: Icon has smooth edges

Actual: Icon has a pixelated edge. See enlarged screenshot.

Device: Flame 3.0 (full flash 319MB)
BuildID: 20150306010207
Gaia: 7a91c16bfa348be8b25e09719178efa051512988
Gecko: 0189941a3fd5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
(Reporter)

Comment 1

4 years ago
This issue does not occur on Flame 2.2, BUT on Flame 2.2 the search engine value selector is NOT RTL'ed, it shows the blue triangle on the right side. I'm not sure if this counts as a regression or not. Possibly whatever made the value selector RTL'ed caused the issue?

Adding regression keyword for now.

Device: Flame 2.2
BuildID: 20150306002519
Gaia: eb86137e247224e86d17ed1a0a133b2a318dce3c
Gecko: a04034e239fb
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
Please see bug 1137547 in regards to the search engine value selector not being RTL'ed in 2.2. This fix was landed on master but not 2.2 yet. We will check this again once the fix has been uplifted to 2.2.
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(pcheng)
blocking-b2g: --- → 2.2?
Priority: -- → P2
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing] [systemsfe]
Summary: [RTL][Rocketbar] Search engine value selector has ugly blue triangle icon → [RTL][Rocketbar] Search engine value selector blue triangle icon looks jagged
blocking 2.2 as this is a fallout from this landing : https://bugzilla.mozilla.org/show_bug.cgi?id=1137547
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
Assignee: nobody → bfrancis

Updated

4 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 4

4 years ago
Confirmed that this issue is affecting 2.2 after the uplift.

Device: Flame 2.2 (full flash, 319MB)
BuildID: 20150311002522
Gaia: 3f032238a52f08e4c2f68a47ad065a96eb22d470
Gecko: 004fa1cb1dd4
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [rtl-impact][QAnalyst-Triage-] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(pcheng) → needinfo?(ktucker)
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

4 years ago
Attachment #8576148 - Flags: review?(dale)
Comment on attachment 8576148 [details] [review]
[gaia] benfrancis:1140525 > mozilla-b2g:master

Looks great cheers
Attachment #8576148 - Flags: review?(dale) → review+
(Assignee)

Comment 7

4 years ago
Thanks Dale
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S8 (20mar)
Posted image Verify_master.png
The bug has been verifyed successfully on master.

Flame 3.0:
Build ID               20150312160232
Gaia Revision          eabe35cf054d47087b37c1ca7db8143717fbd7f3
Gaia Date              2015-03-12 18:01:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/42afc7ef5ccb
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.194521
Firmware Date          Thu Mar 12 19:45:32 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage+][MGSEI-Triage+]
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15445/
Flags: in-moztrap+
Please request Gaia v2.2 on this when you get a chance.
Flags: needinfo?(bfrancis)
(Assignee)

Comment 12

4 years ago
Comment on attachment 8576148 [details] [review]
[gaia] benfrancis:1140525 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: pixelated UI
[Testing completed]: Manual
[Risk to taking this patch] (and alternatives if risky): Low, one line CSS change
[String changes made]: none
Flags: needinfo?(bfrancis)
Attachment #8576148 - Flags: approval-gaia-v2.2?
Attachment #8576148 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Verified fixed on b2g v2.2 with the same Steps to Reproduce as comment 0.

Gaia-Rev        4e0633463571377ad4badc680b666771684e862d
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/535ec28fb36f
Build-ID        20150319162506
Version         37.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150319.200823
FW-Date         Thu Mar 19 20:08:34 EDT 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.