red star default desktop icon is offending to many people

VERIFIED INVALID

Status

defect
--
trivial
VERIFIED INVALID
18 years ago
15 years ago

People

(Reporter: robert.pollak, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Once again this topic turned in n.p.m.general into a place of flamewar
- see the current thread "WTF! mozilla,".

CC'ing hecker@mozilla.org as Henri Sivonen proposed there.

And let me quote Henri
> Some people in California in 1998 thought it was a revolutionary symbol 
> for something that is supposed to be revolutionary.
> 
> It's a bad choice, IMO. It is useless to try to explain the bad 
> connotations away.

!Important: Any advocacy should be continued in the newsgroup!
Use bugzilla only for >>>comments about technical problems of fixing this<<<.

First technical question:
The icon is probably a resource for building the installer. Which
filetype/size/color depth is it? Does it make sense to attach replacement
proposals here?
(Reporter)

Updated

18 years ago
Target Milestone: --- → mozilla1.0

Comment 1

18 years ago
The star is not an error. Replacements do not make sense, there is nothing that
needs fixing. If you propose taking "politics" to the newsgroups, please follow
your own advice. This bug is invalid - resolving as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
> The star is not an error.

AFAIK, mozilla.org is trying to produce a browser and the purpose of Mozilla and
mozilla.org is not to offend people or promite regime(s) commonly associated
with the red star. Evidence from numerous NG threads suggests that some people
find the red star offensive, so arguing that it isn't offensive is pointless.

Considering that the red star is a problem to some and keeping it isn't
essential to Mozilla, this is a valid bug.

> Replacements do not make sense,

Using the letter M as on Mac OS X makes sense: it works as an icon but doesn't
come with the connotations of the red star.
 
Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
This is a duplicate... This issue has already been discussed to death in
bugzilla bugs...
Target Milestone: mozilla1.0 → ---
invalid. This is a dupe, too busy to search.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

18 years ago
Yes, this is a dup of bug 43647. Seems I was not the only one who had
difficulties finding this.

Comment 6

17 years ago
If this really is a duplicate of bug 43647 it should be marked as such, not
RESOLVED INVALID.  I'm not convinced this is a dupe though; even though this
issue has been discussed there, that bug is about the ugliness of all icons,
this one is about the red star's offensiveness.  If bugzilla supported related
bugs (bug 12286), they should definitely be marked as related though.

Also, this one should possibly be categorized in Tech Evangelism, not Browser.

Comment 7

17 years ago
*** Bug 145624 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Yes, this is now the politics bug, I agree.

Somebody should v. this.

(communism, communist)
jesus, nice bugspam

long live money
Status: RESOLVED → VERIFIED

Comment 10

17 years ago
The red stars seem to be disappearing from my KDE menus and window titles. I
understand that for those (IMO misguided) idealists for whom this symbol meant
something good, this would be a difficult decision. Many thanks.

Comment 11

15 years ago
I still see the red star in 1.8alpha1 in the "About Mozilla."  I know there is a
lot of nostalgia to the star for the netscape employees that were recently let
go and to some that have follow Mozilla since '98, but this has offended me and
many others that I know.  The star smacks of communistic ideology.  How hard
would it be to make another design?  This logo was definitely not made by a
sociologist.  The logo needs updated anyway.  It was made way back in 1998.  Why
not make a new logo for Mozilla 2.0?       
Open Source is a communist method of production, so the red star is a natural
symbol for Mozilla project. The source code (the means of production) belongs to
the community, and MPL abolishes any privatization of it, this makes Mozilla
communist by definition.

Look through your English dictionaries for the definition of the word "communist".

http://mithgol.pp.ru/Mozilla/

Comment 13

15 years ago
I think we should take away any window from any building: it offenses me 
reminding about M$ (mis?)operating system.  ;-) 
Bruno 
  
 (In reply to comment #11) 
> I still see the red star in 1.8alpha1 in the "About Mozilla."  I know there 
is a 
> lot of nostalgia to the star for the netscape employees that were recently 
let 
> go and to some that have follow Mozilla since '98, but this has offended me 
and 
> many others that I know.  The star smacks of communistic ideology.  How hard 
> would it be to make another design?  This logo was definitely not made by a 
> sociologist.  The logo needs updated anyway.  It was made way back in 1998.  
Why 
> not make a new logo for Mozilla 2.0?        
 
 
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.