messaging from private chat tab does not show the addressee

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: pali, Assigned: rginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Steps to reproduce:
1. Open private chatr with somebody. 
2. In that tab use /msg somebodyElse some text
3. some text appears to be send to the person you chat with in the current tab
(it is sent correctly though)

Expexcted results: show /msg in standard form ie. to(somebodyElse) sometext

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
Created attachment 118842 [details] [diff] [review]
patch v1

(1) To the user whose view exists

  The message is displayed in his/her view.

(2) To the user whose view doesn't exist

(2-1) In user view 

  The message is displayed in the network view.

(2-2) In network/channel view

  The message is displayed in the current view.

Updated

16 years ago
Attachment #118842 - Flags: review?(rginda)

Comment 2

16 years ago
Created attachment 124109 [details] [diff] [review]
patch v2

patch v1 can't be applied for the latest trunk(Chatzilla 0.8.31).
Attachment #118842 - Attachment is obsolete: true

Comment 3

16 years ago
*** Bug 209210 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Attachment #118842 - Flags: review?(rginda)
(Assignee)

Comment 4

16 years ago
Comment on attachment 124109 [details] [diff] [review]
patch v2

I've applied the first chunk of this patch.  The second one doesn't seem to be
required.
Attachment #124109 - Flags: review+
(Assignee)

Comment 5

16 years ago
marking fixed, 0.8.34 checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.