CSS autocompletion sometimes not working

RESOLVED DUPLICATE of bug 1191093

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 1191093
3 years ago
2 years ago

People

(Reporter: jomo, Unassigned)

Tracking

38 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8574716 [details]
devtools_completion_bug.gif

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150309004203

Steps to reproduce:

I have been working with the Inspector/CSS Rules for a while and at some point CSS Rule suggestions didn't show up.


Actual results:

Browser Console output:

TypeError: this._list.ensureIndexIsVisible is not a function [autocomplete-popup.js:300:4]
TypeError: this._panel.hidePopup is not a function [autocomplete-popup.js:156:4]
TypeError: this._list.ensureIndexIsVisible is not a function [autocomplete-popup.js:300:4]


Expected results:

I expected the CSS rule suggestions to show up.
(Reporter)

Updated

3 years ago
Component: Untriaged → Developer Tools: Inspector

Comment 1

2 years ago
Do you think this bug could be a duplicate of bug 1170013?
Next time you experience this bug, please tell if it was caused by reloading a page
Flags: needinfo?(mozilla)
(Reporter)

Updated

2 years ago
Flags: needinfo?(mozilla)
(Reporter)

Comment 2

2 years ago
Yep, that seems to be the case. I can reproduce this bug every time I reload the page with the dev tools open.

Comment 3

2 years ago
(In reply to jomo from comment #2)
> Yep, that seems to be the case. I can reproduce that bug every time
You should leave it opened, because this issue may also be caused by some other actions than reloading page.
Just pay attention next time it happens

Updated

2 years ago
See Also: → bug 1170013

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1191093
You need to log in before you can comment on or make changes to this bug.