Improve 'about:home' tabs in the tab drawer

RESOLVED FIXED

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: smooney, Assigned: bnicholson)

Tracking

unspecified
ARM
iOS 8

Firefox Tracking Flags

(fennec+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

47 bytes, text/x-github-pull-request
wesj
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
Created attachment 8575092 [details]
grey tabs

I am running the iOS (build 4 I believe). I create a bunch of tabs which seem fine. I go back to the tab view and one or more will show up as grey. This happened a couple of times. I can try and see if I can reproduce it reliably. I attached a screen shot.
That blank grey row with no title and no indicative screenshot is 'about:home'. We should make this obvious like we do in Android.
tracking-fennec: --- → ?
OS: Mac OS X → iOS 8
Hardware: x86 → ARM
Summary: Tabs in the tab view turn "grey" → Improve 'about:home' tabs in the tab drawer
(Reporter)

Comment 2

4 years ago
I sort of understand what you mean. If you create a new new tab, don't search for anything you see a blank tab at the bottom which is white. I actually had content in all these tabs though and it looks like it just disappeared. I wasn't conscious that I created some about:home tabs.

Updated

4 years ago
tracking-fennec: ? → +
(Assignee)

Updated

4 years ago
Blocks: 1097401
(Assignee)

Comment 3

4 years ago
(In reply to Sheila Mooney from comment #2)
> I sort of understand what you mean. If you create a new new tab, don't
> search for anything you see a blank tab at the bottom which is white. I
> actually had content in all these tabs though and it looks like it just
> disappeared. I wasn't conscious that I created some about:home tabs.

Sounds like there are two issues here: about:home tabs being blank, and then other tabs turning gray. I filed bug 1147625 to address the latter.
(Assignee)

Comment 4

4 years ago
Created attachment 8583384 [details] [review]
Pull request
Assignee: nobody → bnicholson
Attachment #8575092 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8583384 - Flags: review?(sarentz)
(Assignee)

Updated

4 years ago
Attachment #8583384 - Flags: review?(wjohnston)
Comment on attachment 8583384 [details] [review]
Pull request

Some nits in the bug. We removed these from about:home, but not from the tabs tray, so I assume this will make that transition a little nicer. Yay! If you have a bunch of about:home tabs, it would actually be nice to share a screenshot (follow up bug?)

I wonder if we can eventually make Browser's have a getView() method (instead of an exposed WebView), that could return the AboutHomeViewController.view in this case. But... we've got enough balls in the air with how to fix Browser that I'm fine punting for now.
Attachment #8583384 - Flags: review?(wjohnston) → review+
Added a bunch of comments. But the big one is that I don't think this approach for making screenshots works:

"I don't think this will work. The problem is that when you open more than about 6 tabs, WebKit will start suspending the content process. And as a result, the screenshot here will be gray. We already had bug reports of that.

Why don't we screenshot, and cache, before the user navigates away from a tab? Then we always have the most recent screenshot of what the user last saw. From a live tab that we know is in good state to screenshot."
(Assignee)

Comment 7

4 years ago
Yeah, that issue is filed as bug 1145402. For this bug, I'm just improving on existing code by adding about:home support for screenshots, so it probably doesn't make sense to shoehorn that fix into this one.
(Assignee)

Comment 8

4 years ago
Merged with comments addressed.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Attachment #8583384 - Flags: review?(sarentz)
You need to log in before you can comment on or make changes to this bug.