Put reader worker logging behind a pref

RESOLVED FIXED in Firefox 38

Status

()

Toolkit
Reader Mode
P5
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Margaret, Assigned: Margaret)

Tracking

Trunk
mozilla39
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox38 fixed, firefox39 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

3 years ago
Created attachment 8575524 [details] [diff] [review]
Disable reader worker logging by default

I found that I can't read prefs in this worker thread, since importing Services.jsm appears to fail because Components in undefined.

We don't have an immediate need for this logging, and this was out of the scope of what was necessary for bug 1140172, so let's just only make this a thing for local builds for now.
Attachment #8575524 - Flags: review?(dtownsend)
Attachment #8575524 - Flags: review?(dtownsend) → review+
(Assignee)

Comment 2

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/2e4c0d785052
Priority: -- → P5
https://hg.mozilla.org/mozilla-central/rev/2e4c0d785052
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1141803
https://hg.mozilla.org/releases/mozilla-aurora/rev/569f50017065
status-firefox38: --- → fixed
Setting qe-verify- for this bug. Margaret, if you think manual QA verification is in fact required here, please flip the flag.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.