Closed Bug 1141654 Opened 5 years ago Closed 5 years ago

test_settings_change_time_format consistently failing, seems to hang and fail on the homescreen

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dharris, Unassigned)

References

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

The test (test_settings_change_time_format.py) is failing consistently in today's nonsmoke1 suite. Running this case and watching it locally, it seems to skip the FTU and then when it gets to the homescreen it hangs and then fails after around 30 seconds of reaching the homescreen.

Traceback (most recent call last):
   File "/home/flash/Desktop/oliverthor/git/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run

Repro Rate: 10/10

Reproducing manually? No


Device firmware (base)	L1TC100118D0
Device firmware (date)	10 Mar 2015 01:32:31
Device firmware (incremental)	eng.cltbld.20150310.043222
Device firmware (release)	4.4.2
Device identifier	flame
Gaia date	09 Mar 2015 15:11:06
Gaia revision	2fb09da0cb9c
Gecko build	20150310010227
Gecko revision	6686aacf006f
Gecko version	39.0a1
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Ah, this fails because of Bug 1139987.  Didn't know there are test scripts actually look for the status bar info.
Depends on: 1139987
I only have automation brackets for this job on mozilla-central/tinderbox (or nightly, but that's less useful). These probably represent merges from mozilla-inbound or b2g-inbound.

However you can use the gaia revs as an initial shot at a range. The problem probably came from there. It's only if it came from gecko that things get trickier:

First fail: 

http://jenkins1.qa.scl3.mozilla.com/view/Mozilla%20Lab/job/flame-kk-319.mozilla-central.tinderbox.ui.functional.non-smoke.1/257/testReport/%28root%29/test_settings_change_time_format_py%20TestSettingsChangeTimeFormat_test_settings_change_time_format/test_settings_change_time_format_py_TestSettingsChangeTimeFormat_test_settings_change_time_format/

Device firmware (base) 	L1TC100118D0
Device firmware (date) 	03 Mar 2015 17:37:09
Device firmware (incremental) 	eng.cltbld.20150303.203700
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	03 Mar 2015 13:58:43
Gaia revision 	3fc0ac309f5f
Gecko build 	20150303171249
Gecko revision 	c5b90c003be8
Gecko version 	39.0a1

Last pass: 

http://jenkins1.qa.scl3.mozilla.com/view/Mozilla%20Lab/job/flame-kk-319.mozilla-central.tinderbox.ui.functional.non-smoke.1/256/testReport/%28root%29/test_settings_change_time_format_py%20TestSettingsChangeTimeFormat_test_settings_change_time_format/test_settings_change_time_format_py_TestSettingsChangeTimeFormat_test_settings_change_time_format/

Device firmware (base) 	L1TC100118D0
Device firmware (date) 	03 Mar 2015 16:33:03
Device firmware (incremental) 	eng.cltbld.20150303.193254
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	02 Mar 2015 23:05:27
Gaia revision 	4352d56f8c79
Gecko build 	20150303154549
Gecko revision 	44bcd21e59fe
Gecko version 	39.0a1

I suspect:

commit c6492a4f9ef646b0f129db53b06e46f8470d1acf
Merge: bdb089f 5ccb57f
Author: Guillaume C. Marty <gmarty@users.noreply.github.com>
Date:   Tue Mar 3 15:18:44 2015 +0000

    Merge pull request #28278 from gmarty/Bug-1132418-Incorrect-coloured-status-bar-and-icons

    Bug 1132418 - [FTE] Incorrect coloured status bar and icons

(and earlier)

commit 5ccb57f7602bffe2cb4eb8ac3dbaedc62caf0bfd
Author: Guillaume Marty <edo999@gmail.com>
Date:   Wed Feb 18 15:03:16 2015 +0900

    Bug 1132418 - [FTE] Incorrect coloured status bar and icons

To range, I'd track down and run the specific test above against the b2g-inbound tinderbox builds before/after the status bar merge commit before doing anything else.
Fixed by the dependency, however this test now appears to be failing at a different point.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Blocks: 1144686
Created Bug 1144686 for the new failure
No longer blocks: 1144686
Blocks: 1144686
No longer blocks: 1144686
You need to log in before you can comment on or make changes to this bug.