Closed Bug 1141817 Opened 7 years ago Closed 7 years ago

Memory allocations panes always empty in the new perf tool

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

defect
Not set
normal

Tracking

(firefox39 fixed)

RESOLVED FIXED
Firefox 39
Tracking Status
firefox39 --- fixed

People

(Reporter: vporof, Assigned: jsantell)

References

Details

Attachments

(1 file, 1 obsolete file)

I suspect a recent regression. The tree is always empty. No error no nothing.
Jordan, can you take a look at this if you have the time?
Flags: needinfo?(jsantell)
ya
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
Flags: needinfo?(jsantell)
Thanks
Attached patch 1141817-perf.patch (obsolete) — Splinter Review
D:
Attachment #8576810 - Flags: review?(vporof)
Comment on attachment 8576810 [details] [diff] [review]
1141817-perf.patch

Review of attachment 8576810 [details] [diff] [review]:
-----------------------------------------------------------------

OH MY GOD I'M SORRY
Attachment #8576810 - Flags: review?(vporof) → review+
Quick update -- with this actually working, there are still some intermittents that have the "Wrong State: Expected 'attached', but current state is 'detached'" stuff -- changed the order of checking the state before calling allocations, which fixes this
Attachment #8576810 - Attachment is obsolete: true
Attachment #8576824 - Flags: review?(vporof)
Attachment #8576824 - Flags: review?(vporof) → review+
https://hg.mozilla.org/mozilla-central/rev/397b5f9702e7
https://hg.mozilla.org/mozilla-central/rev/e82d05c2c18c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 39
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.