[Settings] Update Carets bug

RESOLVED FIXED in 2.2 S8 (20mar)

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: pivanov, Assigned: pivanov)

Tracking

unspecified
2.2 S8 (20mar)
x86
macOS

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(5 attachments)

As Eric mentioned in bug 1131678

This is a bug that wasn't appearing when I first reviewed Pavel's patch.  Pavel, can you take a look and see what's going on?
I think that this bug is caused by the change Guillaume made on 'forward-light.svg' here:
https://github.com/gaia-components/gaia-icons/commit/5b70287928b1e0356014ebb08d091ecf533e28f8#diff-f0c2f2581b64f8aa551e7b1d3257e1d5

I will create a patch for this one but I will need Eric to ui-r+ :)
Posted image Shot from Device
Attachment #8575662 - Flags: ui-review?(epang)
Thanks~

[Blocking Requested - why for this release]: 
2.2? for breaking existing design.
Patch in bug 1131678 is 2.2+.
blocking-b2g: --- → 2.2?
Comment on attachment 8575662 [details]
Shot from Device

this looks right now, thanks Pavel!
Attachment #8575662 - Flags: ui-review?(epang) → ui-review+
Attachment #8575667 - Flags: review?(arthur.chen)
blocking-b2g: 2.2? → 2.2+
Attachment #8575667 - Flags: review?(arthur.chen) → review+
Thanks Pavel and Eric!

master: 8e37d8bcb42d05777376cc066ddc7a4108f3a047
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Sorry I have to revert this. :( I forgot that the style for RTL needs fix, too. Pavel, could you help create another PR? Thanks.

master: d6e38e28db830500e87114263145de800291b9b3
Status: RESOLVED → REOPENED
Flags: needinfo?(pivanov)
Resolution: FIXED → ---
Comment on attachment 8575667 [details] [review]
patch for Gaia/master

https://github.com/mozilla-b2g/gaia/pull/28828
Flags: needinfo?(pivanov)
ahh ... sorry Arthur I miss this one.
can you check this one to be sure that everything is ok now?
https://github.com/mozilla-b2g/gaia/pull/28828
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(arthur.chen)
Resolution: --- → FIXED
Hey Arthur,
I merge this cause I check this one few time (cause bug 1132230)

Landed to master:
https://github.com/mozilla-b2g/gaia/commit/7e30bffdf203296cedd406aeee27aa2273544c47
Cool, thank you!
Flags: needinfo?(arthur.chen)
Duplicate of this bug: 1140106
Please request Gaia v2.2 on this when you get a chance.
Flags: needinfo?(pivanov)
Target Milestone: --- → 2.2 S8 (20mar)
Comment on attachment 8576462 [details] [review]
[gaia] pivanov:bug-1141840 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: The UI looks unfinished.
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None
Attachment #8576462 - Flags: approval-gaia-v2.2?
Flags: needinfo?(pivanov)
QA Whiteboard: [COM=Text Selection]
Attachment #8576462 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.