All my Try builds fails on OSX with "dyld: Symbol not found: _strndup"

VERIFIED FIXED in Firefox 39

Status

defect
--
major
VERIFIED FIXED
4 years ago
Last year

People

(Reporter: mats, Assigned: glandium)

Tracking

({regression})

unspecified
mozilla39
x86_64
macOS
Dependency tree / graph

Firefox Tracking Flags

(firefox39 fixed)

Details

()

Attachments

(1 attachment)

Try run from the tip of mozilla-inbound *without any changes made by me*:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad88e77dcf53

04:33:07     INFO -  REFTEST INFO | runreftest.py | Running tests: start.
04:33:07     INFO -  dyld: Symbol not found: _strndup
04:33:07     INFO -    Referenced from: /builds/slave/talos-slave/test/build/application/NightlyDebug.app/Contents/MacOS/libmozglue.dylib
04:33:07     INFO -    Expected in: flat namespace
04:33:07     INFO -   in /builds/slave/talos-slave/test/build/application/NightlyDebug.app/Contents/MacOS/libmozglue.dylib
04:33:09  WARNING -  TEST-UNEXPECTED-FAIL | reftest | application terminated with exit code -5
This failure started yesterday or the day before.
Keywords: regression
It seems bug 1141679 is related to it somehow.
Actually, it's bug 1141745, though I fear that might be misdiagnosing the cause.
Thanks.  So would touching CLOBBER in my Try pushes work as a temporary workaround?
Flags: needinfo?(philringnalda)
Would certainly be an interesting experiment, though I don't see any sign that the clobber with the clobberer that they did yesterday did any good, nor do I see any obvious reason why the couple of pushes that got useable builds in the last couple of days actually did get usable builds.
Flags: needinfo?(philringnalda)
Try this:
- add the following to build/mozconfig.common.override:
    mk_add_options "export SCCACHE_RECACHE=1"
- push a try build for mac with that mozconfig change.
- if you get green tests, try again without the mozconfig change.
It failed with the same error.
Bug 1141745 was mentioned as a possible dupe of this and has an assignee.
(In reply to Mats Palmgren (:mats) from comment #8)
> It failed with the same error.

:( did you try touching CLOBBER?
CLOBBER doesn't fix it, and I'm getting close to say it's caused by the combination of bug 868814 and the use of sccache on try, and specifically, the fact that sccache is compiling preprocessed files.
So, it's probably not exactly that. The problem is indeed caused by the combination of bug 868814 and sccache. But when the sccache server starts, MACOSX_DEPLOYMENT_TARGET is not set, and that doesn't make strndup references weak (which happens when MACOSX_DEPLOYMENT_TARGET is set to 10.6).
Blocks: 868814
On try, where we use sccache, a sccache server is started the first time
configure runs the compiler for its checks, and that sccache server is
what does compilations on cache misses.

But compiling with MACOSX_DEPLOYMENT_TARGET in the environment doesn't have
the same effect as without, depending on its value. So
MACOSX_DEPLOYMENT_TARGET needs to be set before any compiler invocation.
Assignee: nobody → mh+mozilla
Attachment #8576533 - Flags: review?(mshal)
Blocks: 1142458
Attachment #8576533 - Flags: review?(mshal) → review+
https://hg.mozilla.org/mozilla-central/rev/efb33ed6f159
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Try OSX builds works now for me.  Thanks!
Status: RESOLVED → VERIFIED
@hiro, I suspect you need to update your local tree.
(In reply to Hiroyuki Ikezoe (:hiro) from comment #17)
> Has this been really fixed? 
> I can still see failures on try.
> 
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=bd3d1244e4ef
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=266ead189253

They are based on 42afc7ef5ccb, which is 6 changesets before the landing of this bug (efb33ed6f159)
Thanks! I totally forgot to update the tree before pushing!
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.