Closed Bug 1142033 Opened 6 years ago Closed 6 years ago

Some Kanji character displayes at wrong position.

Categories

(Firefox :: PDF Viewer, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 41

People

(Reporter: hidenosuke, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-d-cjk][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/5990)

Attachments

(3 files)

Steps to reproduce:
1. Open https://www.release.tdnet.info/inbs/140120150306405843.pdf .

Actual Result:
株 and 式 are overlapped.
A position of 株 seems to be wrong.
OS: Linux → All
Priority: -- → P3
Hardware: x86_64 → All
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-d-cjk]
The character "株" is assigned to U+084D MANDAIC LETTER AN, an RTL character.
Attached file 2015031001.pdf
The original PDF link is dead but I found another link.
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-d-cjk] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-d-cjk][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/5990
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 1175142
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
You need to log in before you can comment on or make changes to this bug.