Closed Bug 1175142 Opened 5 years ago Closed 5 years ago

Update pdf.js to version 1.1.215

Categories

(Firefox :: PDF Viewer, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 41
Tracking Status
firefox41 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1168547 +++

Changes since last update:
#6054 [Firefox] Fix newChannel/asyncFetch fallout from bug 1167053
#6051 [Firefox] Re-add _getTabForBrowser compatibility hack for the addon
#6046 Extract correct PDF format version from the catalog
#5971 Extracts PDFLinkService and PDFHistory APIs
#6063 Tweak the PDFLinkService a bit
#6065 Always traverse the entire parent chain in Page_getInheritedPageProp (issue 5954)
#6062 Revert PR 6024 "[Firefox] Parse all JPEG images in the addon", since it's fixed upstream
#6080 Ensure that PDFHistory does not incorrectly replace the initial document hash (issue 6079)
#6082 Fetch parameters if they are |Ref|s in Pattern color spaces (issue 6081)
#5990 Skip mapping of CIDFontType2 glyphs in fonts with a |IdentityToUnicodeMap|, unless |properties.widths| is defined for the glyph
#6088 Check availability of canvas & PDF before printing
#6089 Update README (Chrome & Opera section)
#5998 Don't map glyphs to certain problematic Thai/Lao Unicode locations (issue 5994)
#6076 Apply padding on <select>, not the button
#6101 Add a test-case for issue 6099 - CalRGB color space where the parameters are a |Ref|
#6093 Slightly improved Crypto unit tests
#6091 Increase the font weight used for non-embedded ArialBlack fonts
#6090 Map missing glyphs to the notdef glyph for TrueType (3, 1) fonts (issue 6068)
#6112 Use the Alternate entry, if it exists, in ICCBased Colour Space dictionaries (issue 5836, issue 5939, issue 6055)
#6114 Ensure that the result of |constructStichedFromIRResult| is a number (issue 6113)
#6122 Fix a typo causing a TypeError when attempting to call pdfHistory_clearHistoryState (issue 6121)
Attached patch Update pdf.js to version 1.1.211 (obsolete) — Splinter Review
r?Mossop for the PdfStreamConverter.jsm changes, r?bdahl/yury for the rest.
Attachment #8623062 - Flags: review?(ydelendik)
Attachment #8623062 - Flags: review?(dtownsend)
Attachment #8623062 - Flags: review?(bdahl)
Comment on attachment 8623062 [details] [diff] [review]
Update pdf.js to version 1.1.211

Review of attachment 8623062 [details] [diff] [review]:
-----------------------------------------------------------------

No real changes here, rs=me
Attachment #8623062 - Flags: review?(dtownsend) → review+
Ryan, if it's not too much trouble, could you please update the patch in this bug to include the latest PDF.js changes?
The reason that I'm asking is that we've just landed a PR which fixed a regression, and it would be good if it was included in the uplift (see https://github.com/mozilla/pdf.js/pull/6120).
Flags: needinfo?(ryanvm)
Flags: needinfo?(ryanvm)
Summary: Update pdf.js to version 1.1.211 → Update pdf.js to version 1.1.215
Changes since last update:
#6125 Remove issue6113.pdf from the test-suite for failing intermittently in Firefox on the Linux bot
#6120 Clear the |getSinglePixelWidth| cache when rendering Type3 fonts (issue 6117)
Attachment #8623062 - Attachment is obsolete: true
Attachment #8623062 - Flags: review?(ydelendik)
Attachment #8623062 - Flags: review?(bdahl)
Attachment #8624181 - Flags: review?(ydelendik)
Attachment #8624181 - Flags: review?(bdahl)
Comment on attachment 8624181 [details] [diff] [review]
Update pdf.js to version 1.1.215

Review of attachment 8624181 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good
Attachment #8624181 - Flags: review?(ydelendik)
Attachment #8624181 - Flags: review?(bdahl)
Attachment #8624181 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/dbbcc1bbe42d
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Blocks: 1182228
No longer blocks: 1182228
Type: defect → task
No longer depends on: 1168547
You need to log in before you can comment on or make changes to this bug.