Closed Bug 1142112 Opened 5 years ago Closed 4 years ago

Robocop should follow same chunking code-path as the rest of mochitest

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1179981

People

(Reporter: ahal, Assigned: gbrown)

References

(Blocks 1 open bug)

Details

Right now robocop has a separate code path for chunking:
https://dxr.mozilla.org/mozilla-central/source/testing/mochitest/runtestsremote.py#811

It should just use getTestsToRun() in runtests.py like every other mochitest variant.
Blocks: chunking
Robocop uses runrobocop.py these days, which uses manifestparser for chunking, just like mochitests.
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1179981
You need to log in before you can comment on or make changes to this bug.