Closed Bug 1142133 Opened 7 years ago Closed 7 years ago

Investigate intermittent fail in test_receive_call_with_locked_screen - TimeoutException: Plivo didn't report the call as completed

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1097754

People

(Reporter: bzumwalt, Unassigned)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

From Traceback, call appears to hang on the lockscreen and not get rejected as expected. Observing local automation while running test_dialer_receive_call_with_locked_screen.py shows two different issues for the same fail message in traceback. For the first (seen on the first and ninth tests), everything on screen appears to go as expected with the call visibly being rejected, but the result for the test shows as failed due to plivo call timeout. In the second scenario (seen second and fifth tests) it appears that the call is rejected from the lockscreen once as expected, but as soon as this happens a second call screen appears and this is not rejected the phone continues to ring/vibrate until the call times out. Passing tests did not appear visibly different from the first result that failed.

Traceback (most recent call last):
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run
    testMethod()
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer_receive_call_with_locked_screen.py", line 44, in test_receive_call_with_locked_screen
    self.plivo.wait_for_call_completed(self.call_uuid)
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/utils/plivo/plivo_util.py", line 64, in wait_for_call_completed
    message="Plivo didn't report the call as completed")
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.1 seconds with message: Plivo didn't report the call as completed


Reproduced 4/10 times on local automation

I was unable to reproduce this issue manually after 10 attempts


Failing history: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/82/testReport/junit/%28root%29/test_dialer_receive_call_with_locked_screen_py%20TestReceiveCallScreenLocked_test_receive_call_with_locked_screen/test_dialer_receive_call_with_locked_screen_py_TestReceiveCallScreenLocked_test_receive_call_with_locked_screen/history/


Device firmware (base)	L1TC100118D0
Device firmware (date)	11 Mar 2015 01:38:50
Device firmware (incremental)	eng.cltbld.20150311.043838
Device firmware (release)	4.4.2
Device identifier	flame
Gaia date	10 Mar 2015 13:35:07
Gaia revision	943c8b4039f5
Gecko build	20150311010231
Gecko revision	fd8e079d6335
Gecko version	39.0a1


Attached html report from locally run automation tests as noted in description.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1097754
You need to log in before you can comment on or make changes to this bug.