test_dialer_receive_call_with_locked_screen.py sometimes doesn't wait until the callscreen arrives at the bottom of the screen

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: viorela, Assigned: jlorenzo)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.1S fixed)

Details

Attachments

(3 attachments, 2 obsolete attachments)

Test test_dialer_receive_call_with_locked_screen.py is failing intermittently on master. 
It is not the first time I see this test failing on master/b2g-inbound.

I couldn't reproduce the failure locally, by running the automated test or manually. 
From the jenkins screenhsot, it looks like the incoming call was not rejected.

We need to still investigate this, and try to reproduce the issue.

Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer_receive_call_with_locked_screen.py", line 51, in test_receive_call_with_locked_screen
message="Plivo didn't report the call as completed")
File "/var/jenkins/1/workspace/flame-kk-319.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.0 seconds with message: Plivo didn't report the call as completed


Device firmware (date)     21 Oct 2014 00:59:42
Device firmware (incremental)     40
Device firmware (release)     4.4.2
Device identifier     flame
Gaia date     11 Nov 2014 10:27:28
Gaia revision     5ae28ff11b98
Gecko build     20141112040208
Gecko revision     688f821edcd4
Gecko version     36.0a1

Jenkins report: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.ui.functional.smoke/122/HTML_Report/
I was not able to reproduce the fail locally 

Started:
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/308/console

Looks like the call is still active after the call is rejected.
Assignee: nobody → florin.strugariu
QA Whiteboard: [fxosqa-auto-s4]
Assignee: florin.strugariu → robert.chira
QA Whiteboard: [fxosqa-auto-s4] → [fxosqa-auto-from-s4] [fxosqa-auto-s5]
Attachment #8531219 - Flags: review?(florin.strugariu) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
The issue is still reproduced.

http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.b2g-inbound.ui.functional.smoke/1484/console
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I tried everything to fix this intermittent:
flick
press + move + release
press + move_to_offset + release

different coordinates

Locally we can't reproduce the issue

Can someone in the lab try to see what's going on
Flags: needinfo?(gmealer)
Assignee: robert.chira → martijn.martijn
QA Whiteboard: [fxosqa-auto-from-s4] [fxosqa-auto-s5] → [fxosqa-auto-from-s4] [fxosqa-auto-from-s5] [fxosqa-auto-s6]
I used http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/ to run this test and then I went to the lab to see the test running, but I couldn't find out on which phone it was running. I tried it out several times.

I also tried to run this test on my local device, which I haven't figured out yet. I sent Johan a mail to help me with that (probably something wrong with my testvars.json file).
There is something wrong on PLIVO_TIMEOUT value.

*** When I set PLIVO_TIMEOUT=20, I always can reproduce this bug. ***
---------------------------------------------------------------------
william@tpemozilla:~/Workspace_B2G/Gaia_Repo/Gaia_Master/tests/python/gaia-ui-tests$ gaiatest --address=localhost:2828 --testvars=/home/william/Workspace_B2G/Gaia_Repo/gaiatestvars_flame_v2dot1.json --restart gaiatest/tests/functional/dialer/test_dialer_receive_call_with_locked_screen.py
Results will not be posted to Treeherder. Please set the following environment variables to enable Treeherder reports: TREEHERDER_KEY, TREEHERDER_SECRET
starting httpd
running webserver on http://10.247.29.43:59665/
SUITE-START | Running 1 tests
TEST-START | test_dialer_receive_call_with_locked_screen.py TestReceiveCallScreenLocked.test_receive_call_with_locked_screen
69913908-85da-11e4-a698-498d468c930b
TEST-UNEXPECTED-ERROR | test_dialer_receive_call_with_locked_screen.py TestReceiveCallScreenLocked.test_receive_call_with_locked_screen | TimeoutException: TimeoutException: Timed out after 20.0 seconds with message: Plivo didn't report the call as completed


Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/marionette_client-0.8.3-py2.7.egg/marionette/marionette_test.py", line 171, in run
    testMethod()
  File "/home/william/Workspace_B2G/Gaia_Repo/Gaia_Master/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer_receive_call_with_locked_screen.py", line 51, in test_receive_call_with_locked_screen
    message="Plivo didn't report the call as completed")
  File "/usr/local/lib/python2.7/dist-packages/marionette_client-0.8.3-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TEST-INFO took 76949ms

SUMMARY
-------
passed: 0
failed: 1
todo: 0

FAILED TESTS
---------------------------------------------------------------------



*** When I set PLIVO_TIMEOUT=60, everything works well. ***
---------------------------------------------------------------------
william@tpemozilla:~/Workspace_B2G/Gaia_Repo/Gaia_Master/tests/python/gaia-ui-tests$ gaiatest --address=localhost:2828 --testvars=/home/william/Workspace_B2G/Gaia_Repo/gaiatestvars_flame_v2dot1.json --restart gaiatest/tests/functional/dialer/test_dialer_receive_call_with_locked_screen.py
Results will not be posted to Treeherder. Please set the following environment variables to enable Treeherder reports: TREEHERDER_KEY, TREEHERDER_SECRET
starting httpd
running webserver on http://10.247.29.43:41783/
SUITE-START | Running 1 tests
TEST-START | test_dialer_receive_call_with_locked_screen.py TestReceiveCallScreenLocked.test_receive_call_with_locked_screen
c6c7306a-85d9-11e4-b19c-498d468c930b
TEST-PASS | test_dialer_receive_call_with_locked_screen.py TestReceiveCallScreenLocked.test_receive_call_with_locked_screen | took 90585ms

SUMMARY
-------
passed: 1
failed: 0
todo: 0
SUITE-END | took 91s
---------------------------------------------------------------------


I would like to apply a local patch on our CI to see if it still happens.
Thanks.
[Approval Request Comment]


[Bug caused by] (feature/regressing bug #):
- Plivo server side response

[User impact] if declined:
- No user impact since it is GU test

[Testing completed]:
- Yes! Passed on local CI
william@tpemozilla:~/Workspace_B2G/Gaia_Repo/Gaia_Master/tests/python/gaia-ui-tests$ gaiatest --address=localhost:2828 --testvars=/home/william/Workspace_B2G/Gaia_Repo/gaiatestvars_flame_v2dot1.json --restart gaiatest/tests/functional/dialer/test_dialer_receive_call_with_locked_screen.py
Results will not be posted to Treeherder. Please set the following environment variables to enable Treeherder reports: TREEHERDER_KEY, TREEHERDER_SECRET
starting httpd
running webserver on http://10.247.29.43:41783/
SUITE-START | Running 1 tests
TEST-START | test_dialer_receive_call_with_locked_screen.py TestReceiveCallScreenLocked.test_receive_call_with_locked_screen
c6c7306a-85d9-11e4-b19c-498d468c930b
TEST-PASS | test_dialer_receive_call_with_locked_screen.py TestReceiveCallScreenLocked.test_receive_call_with_locked_screen | took 90585ms

SUMMARY
-------
passed: 1
failed: 0
todo: 0
SUITE-END | took 91s


[Risk to taking this patch] (and alternatives if risky):
- No risk
Attachment #8538422 - Flags: approval-gaia-v2.1?
Hi, Martijn,

May I have your help to review my patch?
Thanks.
Attachment #8538422 - Flags: review?(martijn.martijn)
 William Do we know why changing the time-out we fix this issue?

This is still failing on v2.2  so we would like to go to master first
Flags: needinfo?(whsu)
Attachment #8538422 - Attachment is patch: true
Yeah, that is my question too. Why is this making the intermittent failure go away?
I mean, the call is terminated by the device pretty soon, why is that apparently sometimes taking much longer?
PLease seek branch approval only once the issue is landed and verified on master.
Hi,  Florin and  Martijn,

I tried to find the regression window but I found that this bug also happens on very old build.
So, I think there is something wrong on system configuration. (Gaia UI test)

I narrowed down the impact factors and I found the Plivo server response time was not very stable when I executed this test case.

Therefore, I traced into following function, and then adjust PLIVO_TIMEOUT value.
After that, everything works well.

Wait(self.plivo, timeout=PLIVO_TIMEOUT).until(
    lambda p: p.is_call_completed(self.call_uuid), message="Plivo didn't report the call as completed"
)

Thanks. Have a nice day! :)
Flags: needinfo?(whsu)
Comment on attachment 8538422 [details] [diff] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26876

Thanks, that makes sense, I guess.
Attachment #8538422 - Flags: review?(martijn.martijn) → review+
William, please seek review from jlorenzo before landing anything, since he's been taking point on Plivo. 

Couple of things to note: We generally require two reviews to land on master. At least one should come from our team, probably both since we own trunk. 

For 2.1, we're going to have to work out the balance between Device Team maintaining the branch, and permission required for uplifts. We won't necessarily always be taking changes into master, since the UI may change there, so bhavana's request may or may not always apply. I'm hoping we can get a Not Part of the Build exemption on some of that.

NI'ing you and Johan for visibility on that review guideline, but no particular response required from either.
Flags: needinfo?(whsu)
Flags: needinfo?(jlorenzo)
Flags: needinfo?(gmealer)
WoW! Guys... you have worked overtime. :P
----------------------------------------------------

Hi, Martijn,

Thanks for your help. :)


Hi, Geo,

Sure! If Johan can help on this, I think reconfirmation is good even if the patch doesn't belong to master branch.
By the way, as you said, the UI presentation is not the same in different branches.
So, we need a process to handle this.
Perhaps, Softvision team has better idea since they have handled these similar situations many times.
Flags: needinfo?(whsu)
(In reply to Florin Strugariu [:Bebe] from comment #10)
>  William Do we know why changing the time-out we fix this issue?
> 
> This is still failing on v2.2  so we would like to go to master first

Hi, Florin,
My bad. I don't know the uplift process of GU test so I submit a pull request on v2.1 branch.
I will close original one and submit a new request on master.
Thanks.
Test result of master branch.
Pull request will be attached later.
--- -- - --- -- - --- -- - --- -- - --- -- -
william@tpemozilla:~/Workspace_B2G/Gaia_Repo/tests/python/gaia-ui-tests$ gaiatest --address=localhost:2828 --testvars=/home/william/Workspace_B2G/Gaia_Repo/gaiatestvars_flame_v2dot1.json --restart gaiatest/tests/functional/dialer/test_dialer_receive_call_with_locked_screen.py
Results will not be posted to Treeherder. Please set the following environment variables to enable Treeherder reports: TREEHERDER_KEY, TREEHERDER_SECRET
starting httpd
running webserver on http://10.247.29.43:44212/
mozversion application_buildid: 20141218160209
mozversion application_changeset: 1427b365cd39
mozversion application_display_name: B2G
mozversion application_id: {3c2e2abc-06d4-11e1-ac3b-374f68613e61}
mozversion application_name: B2G
mozversion application_remotingname: b2g
mozversion application_repository: https://hg.mozilla.org/mozilla-central
mozversion application_vendor: Mozilla
mozversion application_version: 37.0a1
mozversion device_firmware_date: 1418948855
mozversion device_firmware_version_base: L1TC00011880
mozversion device_firmware_version_incremental: eng.cltbld.20141218.192724
mozversion device_firmware_version_release: 4.4.2
mozversion device_id: flame
mozversion gaia_changeset: 2650bae535e15eef5f299cc80d4fab460f78ada7
mozversion gaia_date: 1418932878
mozversion platform_buildid: 20141218160209
mozversion platform_changeset: 1427b365cd39
mozversion platform_repository: https://hg.mozilla.org/mozilla-central
mozversion platform_version: 37.0a1
SUITE-START | Running 1 tests
TEST-START | test_dialer_receive_call_with_locked_screen.py TestReceiveCallScreenLocked.test_receive_call_with_locked_screen
TEST-PASS | test_dialer_receive_call_with_locked_screen.py TestReceiveCallScreenLocked.test_receive_call_with_locked_screen | took 97647ms

SUMMARY
-------
passed: 1
failed: 0
todo: 0
SUITE-END | took 98s

william@tpemozilla:~/Workspace_B2G/Gaia_Repo/tests/python/gaia-ui-tests$ git branch | awk '/\*/ { print $2; }'
master
Pull request of master branch.
Attachment #8539115 - Flags: review?(martijn.martijn)
Attachment #8539115 - Flags: review?(jlorenzo)
Hi, Martijn and Johan,

I re-create a pull request on master branch.
Could I have your help to review this patch again?
Thanks.
Comment on attachment 8539115 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26908

I am not against increasing the timeout value on this test, especially when the test doesn't fail after 50 runs[1]. We might want to do that each of our tests by the way.

[1] http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/478/console
Flags: needinfo?(jlorenzo)
Attachment #8539115 - Flags: review?(jlorenzo) → review+
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #22)
> Comment on attachment 8539115 [details] [review]
> Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26908
> 
> I am not against increasing the timeout value on this test, especially when
> the test doesn't fail after 50 runs[1]. We might want to do that each of our
> tests by the way.
> 
> [1] http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/478/console

That makes me wonder if there should be a followup bug about centralizing the default timeout value, assuming there's not already a default we can't just bump. Seems unlikely there'll be a situation where different tests want radically different values in the normal case.
Attachment #8539115 - Flags: review?(martijn.martijn) → review+
Blocks: 1113953
Hi, Johan and Martijn,

Thanks for your help and review!
Have a nice weekend! :)

--- -- - --- -- - --- -- - --- -- - --- -- -
Hi, Geo,

You're right
We can file a follow up and evaluate it to see if it worth to centralize the default timeout value.
Bug was submitted. (Bug 1113953)

Thanks! :)
No longer blocks: 1113953
Blocks: 1113953
No longer blocks: 1113953
After looking at comment 21, this simple fix seems to be not be enough. Moreover, Plivo didn't report any issue the day we run the test: https://status.plivo.com/past_week/ https://status.plivo.com/incident_reports/.
Attachment #8538422 - Flags: approval-gaia-v2.1?
(In reply to Florin Strugariu [:Bebe] from comment #21)
> Started http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/480/

It looks interesting.
So, we can narrow down this problem.
Adjusting Plivo timeout will impact test result but we can say...
1) Plivo timeout value = 60 is not a appropriate value
2) there seems to be something wrong with subfunction invoking between "Wait(self.marionette).until(lambda m: condition)" and reject_call(self)

:)
(In reply to William Hsu [:whsu] from comment #26)
> (In reply to Florin Strugariu [:Bebe] from comment #21)
> > Started http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/480/

In that Jenkins run it failed 4 times out of 31 times:
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/480/HTML_Report/
1 time, it is failing in a different way. In that cases, it seems that the call was terminated already in some way before reject_call was invoked.

In the other 3 cases, it looks like reject_call didn't work, because the screenshot clearly shows the call is still going on and the failure happens right after reject_call was called:
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer_receive_call_with_locked_screen.py#49

http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/apps/phone/regions/call_screen.py#148
It looks like self._handle_incoming_call('reject') didn't work.
But that makes me wonder why it doesn't fail on self.wait_for_element_not_displayed(*self._call_screen_locator)
Perhaps that's the wrong element to wait for? 
It seems like we could just use self.wait_for_element_not_displayed(*self._lockscreen_handle_locator) there.
But that would probably not fix the failure.

Apparently, the fling action in _handle_incoming_call is not working all the time:
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/apps/phone/regions/call_screen.py#143
I have no idea why.
(In reply to Martijn Wargers [:mwargers] (QA) from comment #27)
> It looks like self._handle_incoming_call('reject') didn't work.
> But that makes me wonder why it doesn't fail on
> self.wait_for_element_not_displayed(*self._call_screen_locator)
> Perhaps that's the wrong element to wait for? 

Actually, that is the right element to wait for.
I think that we should use that also instead of the self.wait_for_element_not_displayed(*self._lockscreen_handle_locator) beforehand.
Sorry, did something wrong with the Jenkins run, here's a better one:
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/517/
Oops, no, that didn't work.
QA Whiteboard: [fxosqa-auto-from-s4] [fxosqa-auto-from-s5] [fxosqa-auto-s6] → [fxosqa-auto-from-s4] [fxosqa-auto-from-s5] [fxosqa-from-s6][fxosqa-auto-s7][fxosqa-auto-points=4]
I tried now with a small time.sleep(1) call: https://github.com/mozilla-b2g/gaia/pull/26993
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/539/
I haven't seen the failure in there, but there is something else going on that's causing failures. I heard there were issues with Plivo?
Johan on IRC:
19:29 jlorenzo: mwargers: try adding self.wait_for_condition(lambda m: incoming_call.location['y'] == 0) between self.wait_for_condition(lambda m: self.is_element_displayed(*self._incoming_call_locator)) and self.wait_for_condition(lambda m: self.incoming_calling_contact != u'') in wait_for_incoming_call_with_locked_screen

I'm currently stuck with a different failure, namely the one mentioned in comment 32.
Stealing (like discussed on IRC with Martijn).

I think I found out what's going wrong. Plivo doesn't report the call as completed because the call is still ringing[1]. The problem here is that we don't wait until the callscreen arrives[2] at the bottom of the screen like we do when the screen is unlocked[3]. So sometimes, while the callscreen is sliding down, Marionette gets the coordinates of the answer bar (which are not definitive because of the transition), use them to swipe to refuse the call. But, as the coordinates are wrong, Marionette doesn't execute the swipe movement on the answer_bar.

That's probably why, Marionette waits for Plivo to complete the call while Plivo is still waiting for somebody to refuse the call.

[1] http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/480/HTML_Report/
[2] https://github.com/mozilla-b2g/gaia/blob/c67fb679c90372e42e5c48df48da7ccac8047211/tests/python/gaia-ui-tests/gaiatest/apps/phone/regions/call_screen.py#L101
[3] https://github.com/mozilla-b2g/gaia/blob/c67fb679c90372e42e5c48df48da7ccac8047211/tests/python/gaia-ui-tests/gaiatest/apps/phone/regions/call_screen.py#L94
Assignee: martijn.martijn → jlorenzo
Comment on attachment 8538422 [details] [diff] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26876

This PR was closed before it got landed.
Attachment #8538422 - Attachment is obsolete: true
Comment on attachment 8539115 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26908

This patch wasn't enough to fix the issue (like discovered in comment 21).
Attachment #8539115 - Attachment is obsolete: true
Summary: Investigate intermittent failure of test_dialer_receive_call_with_locked_screen.py → test_dialer_receive_call_with_locked_screen.py sometimes doesn't wait until the callscreen arrives at the bottom of the screen
I merged wait_for_incoming_call() and wait_for_incoming_call_with_locked_screen(), they were waiting on the same locators.

I updated the unified locator because the corresponding element didn't have a constant size depending if the lock screen was on or not. This made the wait on "location['y'] == 0" useless. By the way, this new ID doesn't have an explicit name. I'll ask the Dialer devs about it.

I also ran this adhoc job[1]. No failure at all after 101 tries.

[1] http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/548
Attachment #8545255 - Flags: review?(viorela.ioia)
Attachment #8545255 - Flags: review?(martijn.martijn)
The new ID is due to historical reasons. I opened bug 1118787 to track the fix in Dialer.
Comment on attachment 8545255 [details] [review]
Gaia PR (second patch)

If this fixes the intermittent failure, then great!
Attachment #8545255 - Flags: review?(martijn.martijn) → review+
Comment on attachment 8545255 [details] [review]
Gaia PR (second patch)

r+, it's great to have 101 runs of this tests and no failure!
Merged in: https://github.com/mozilla-b2g/gaia/commit/8c0d0e981c38676136fa5fa82aeffb14b1ebdccc
Attachment #8545255 - Flags: review?(viorela.ioia) → review+
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Hi, Viorela,

Could you please help uplift this patch to v2.1?
Many thanks.
Flags: needinfo?(viorela.ioia)
Same patch as master. No merge issue to report.
Flags: needinfo?(viorela.ioia)
Attachment #8547422 - Flags: review?(viorela.ioia)
Comment on attachment 8547422 [details] [review]
Gaia PR (second patch) - 2.1

Meregd in v2.1: https://github.com/mozilla-b2g/gaia/commit/836e6d74cb8b7016df555f85445893b3ff9aac12
Attachment #8547422 - Flags: review?(viorela.ioia) → review+
(In reply to Viorela Ioia [:viorela] from comment #43)
> Comment on attachment 8547422 [details] [review]
> Gaia PR (second patch) - 2.1
> 
> Meregd in v2.1:
> https://github.com/mozilla-b2g/gaia/commit/
> 836e6d74cb8b7016df555f85445893b3ff9aac12

Thanks Viorela! :)
This error reappeared in today's test run:
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.smoke/260/HTML_Report/

Device firmware (base) 	L1TC10011880
Device firmware (date) 	14 Jan 2015 01:54:09
Device firmware (incremental) 	eng.cltbld.20150114.045357
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	13 Jan 2015 13:17:08
Gaia revision 	e2a0f7c31111
Gecko build 	20150114010205
Gecko revision 	63006936ab99
Gecko version 	38.0a1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
QA Whiteboard: [fxosqa-auto-from-s4] [fxosqa-auto-from-s5] [fxosqa-from-s6][fxosqa-auto-s7][fxosqa-auto-points=4] → [fxosqa-auto-from-s4][fxosqa-auto-from-s5][fxosqa-from-s6][fxosqa-auto-from-s7][fxosqa-auto-s8][fxosqa-auto-points=4]
Duplicate of this bug: 1142133
Gaia UI tests are not run or maintained anymore.
Status: REOPENED → RESOLVED
Closed: 5 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.