Closed Bug 1142302 Opened 7 years ago Closed 7 years ago

[Complete Themes] Applying filters to search results - Any Firefox and All Systems - returns an incorrect result set

Categories

(addons.mozilla.org Graveyard :: Search, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: mbrandt, Unassigned)

References

()

Details

(Whiteboard: [fromAutomation])

Attachments

(1 file)

Complete Themes search results appear to include incorrect results when a user expands results (using the Filter Results sidebar) to include 'Any Firefox' version and 'All Systems.'

This is reproducible on dev/stage/prod.

Steps to reproduce:
0. From the themes navigation menu, select 'Complete Themes', which will load https://addons.mozilla.org/firefox/complete-themes/
1. In the addons search field, search for 'nasa'
2. In the Filter Results sidebar - expand search to include 'Any Firefox' and 'All Systems'

The test expects:
Search results only include Complete Themes for Nasa.

Actual:
Search results include non-complete theme results. The Filter Results category filter defaults to 'All Add-ons.'

For example, https://addons.mozilla.org/firefox/addon/bt-nasathemes/?src=search, is included in the search results. Test automation fails because it is marked as an extension, not a complete theme.
OS: Mac OS X → All
Hardware: x86 → All
Mathieu, Krupa - can you help us sort this out?  Thanks!  :-)
Flags: needinfo?(mathieu)
For posterity and cross-reference, see also bug 1117739.
Isn't that expected? I mean, when you enter a search, it doesn't keep the category, not sure if it should (the search bar is "global" to the site, not to the current category, right?).

What I mean is: is this a regression, or a feature request?

Krupa, do you have an opinion on this?
Flags: needinfo?(mathieu) → needinfo?(krupa.mozbugs)
Search is not determined based on the page you do the search from. As in, when you do the search, all results are returned and you can then filter using the menu.

Thanks.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(krupa.mozbugs)
Resolution: --- → INVALID
Thanks all -- just wanted to double check this before coding it into our tests. The question arose because we do set filters based off of env and version of Firefox.
Status: RESOLVED → VERIFIED
We addressed this in https://github.com/mozilla/Addon-Tests/pull/758, to pull things together a bit more.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.