'www.sohu.com' serves desktop content to Firefox OS instead of 'm.sohu.com'

RESOLVED DUPLICATE of bug 985277

Status

Tech Evangelism
Mobile
RESOLVED DUPLICATE of bug 985277
3 years ago
3 years ago

People

(Reporter: josh, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Other
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.1S affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [mobile-compat-form] [country-cn] [serversniff] , URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Site: www.sohu.com
'www.sohu.com' serves desktop content to Firefox OS instead of 'm.sohu.com'

:: Steps To Reproduce

Site: http://www.sohu.com/

:: Steps To Reproduce
1. Use Firefox on Firefox OS
2. Go to http://www.sohu.com/

:: Expected Result
Receive a mobile friendly content 'm.sohu.com' like it is happening for Safari iOS.

:: Actual Result
Received the Desktop Content.

:: Expected Result

Receive a mobile friendly content 'm.sohu.com'

:: Actual Result

Received the Desktop Content.

:: Additional Information

Software Version: 2.0M
Device Information: Woodduck 2.0M
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.65 Safari/537.36
Created attachment 8576370 [details]
Video.mp4

This issue can be repro on Woodduck 2.0M, Flame 2.0/2.1/2.1s/2.2/3.0 and Nexus 5.

Attached: Video.mp4&logcat.txt
Found at: 8:52pm.
Rate: 100%

Woodduck 2.0M
Build ID               20150312050313
Gaia Revision          0e0a84a03f7253d1544e6e8ecbadac9d0f325a64
Gaia Date              2015-03-11 05:43:46
Gecko Revision         4dd211ecc070564dea1af8fc5125cfc748f24a23
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1426107908
Firmware Date          Thu Mar 12 05:05:26 CST 2015
------------------
Flame 2.0:
Build ID               20150311000206
Gaia Revision          896803174633fc6acd3fd105f81c349b8e9b9633
Gaia Date              2015-03-10 06:32:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/78df3174fb10
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.034723
Firmware Date          Wed Mar 11 03:47:34 EDT 2015
Bootloader             L1TC000118D0
------------------
Flame 2.1:
Build ID               20150311001232
Gaia Revision          04623ffbdc1e9c53de5a9a522bc9d8d93020a56d
Gaia Date              2015-03-10 18:12:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/421ee858039c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.040426
Firmware Date          Wed Mar 11 04:04:37 EDT 2015
Bootloader             L1TC000118D0
------------------
2.1S 512MB:
Build ID               20150310161205
Gaia Revision          a66813e488374b8ba9d8aa187b00f84ad5bd1bb9
Gaia Date              2015-03-10 06:56:29
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/ee8a2d1b86a5
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
------------------
Flame 2.2:
Build ID               20150311002522
Gaia Revision          3f032238a52f08e4c2f68a47ad065a96eb22d470
Gaia Date              2015-03-11 00:28:07
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/004fa1cb1dd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.040546
Firmware Date          Wed Mar 11 04:05:57 EDT 2015
Bootloader             L1TC000118D0
----------------
N5_2.2
Build ID               20150311002522
Gaia Revision          3f032238a52f08e4c2f68a47ad065a96eb22d470
Gaia Date              2015-03-11 00:28:07
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/004fa1cb1dd4
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150311.040337
Firmware Date          Wed Mar 11 04:03:52 EDT 2015
Bootloader             HHZ12d
----------------
Flame 3.0:
Build ID               20150311010231
Gaia Revision          943c8b4039f59b08ba100390e164a076a20c892e
Gaia Date              2015-03-10 20:35:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fd8e079d6335
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.043838
Firmware Date          Wed Mar 11 04:38:50 EDT 2015
Bootloader             L1TC000118D0
Created attachment 8576371 [details]
logcat.txt
Blocks: 1054172, 1080481
Group: woodduck-confidential
Status: UNCONFIRMED → NEW
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.1S: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Ever confirmed: true
(Reporter)

Updated

3 years ago
Group: woodduck-confidential

Updated

3 years ago
Group: woodduck-confidential
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [country-cn] [serversniff]
Duplicate of bug: 985277

Updated

3 years ago
Group: woodduck-confidential

Comment 4

3 years ago
Sorry josh about the flag changing, our save changes crossed each other. Thanks for the change. ^_^ Appreciated.
You need to log in before you can comment on or make changes to this bug.