Unexpected line break inside <li>

RESOLVED FIXED in Firefox 38

Status

()

Core
Layout
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: xidorn)

Tracking

({regression})

Trunk
mozilla39
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox36 affected, firefox37 affected, firefox38 fixed, firefox39 fixed, firefox-esr31 unaffected)

Details

(Whiteboard: [parity-Chrome][parity-IE])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8576377 [details]
index.html

Steps To reproduce:
1: Open attached

Actual Results:
Unexpected line break

Expected results:
No line break

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6fcbe7b1dec2&tochange=1f7ccdfe2c6e

Regressed by: Bug 1013160
Flags: needinfo?(quanxunzhen)
(Reporter)

Comment 1

3 years ago
Created attachment 8576384 [details]
screenshot
(Reporter)

Updated

3 years ago
Whiteboard: [parity-Chrome][parity-IE]
(Reporter)

Updated

3 years ago
Blocks: 1142340
Created attachment 8576446 [details] [diff] [review]
patch
Assignee: nobody → quanxunzhen
Flags: needinfo?(quanxunzhen)
Attachment #8576446 - Flags: review?(roc)
Thanks for reporting this bug. I think I noticed this problem before, but didn't know the impact of it, neither how can I test it. But when I know the impact, I've forgotten this problem :)
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 32 Branch → Trunk
Created attachment 8576449 [details] [diff] [review]
patch

forgot to add reftest
Attachment #8576446 - Attachment is obsolete: true
Attachment #8576446 - Flags: review?(roc)
Attachment #8576449 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/b7027d5ce2fe
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: affected → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Comment on attachment 8576449 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1013160
[User impact if declined]: see undesired line break inside <li> if they put them in float block or table.
[Describe test coverage new/current, TreeHerder]: related reftest is included in this patch
[Risks and why]: not aware of any risk
[String/UUID change made/needed]: n/a
Attachment #8576449 - Flags: approval-mozilla-aurora?
status-firefox-esr38: ? → ---
Comment on attachment 8576449 [details] [diff] [review]
patch

Approving for uplift to aurora since this has test coverage and sounds low risk.
Attachment #8576449 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.