Move MODULE_OPTIMIZE_FLAGS to moz.build

RESOLVED DUPLICATE of bug 1186444

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1186444
3 years ago
2 months ago

People

(Reporter: Ms2ger, Unassigned, Mentored)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment 1

3 years ago
Created attachment 8588346 [details] [diff] [review]
bug1142513.patch
Attachment #8588346 - Flags: review?(Ms2ger)
(Reporter)

Updated

3 years ago
Attachment #8588346 - Flags: review?(Ms2ger) → review?(gps)

Comment 2

3 years ago
Comment on attachment 8588346 [details] [diff] [review]
bug1142513.patch

Review of attachment 8588346 [details] [diff] [review]:
-----------------------------------------------------------------

While I understand why you would want to convert MODULE_OPTIMIZE_FLAGS to CFLAGS assignments, this conversion changes behavior. If you look in config/config.mk, you'll notice that MODULE_OPTIMIZE_FLAGS is conditionally used if MOZ_OPTIMIZE is defined.

What this patch does is convert -O appends from conditional to constant. This is almost certainly undesirable if people have explicitly disabled optimizations.
Attachment #8588346 - Flags: review?(gps) → review-
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1186444

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.