OTA for Flame Kitkat 2.2, 2.1, and 2.0 builds does not download the latest Nightly builds.

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({qablocker, regression, smoketest})

unspecified
x86
Linux
qablocker, regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified, b2g-v2.1S fixed, b2g-v2.2 verified)

Details

(Reporter)

Description

4 years ago
The latest nightly builds are not available in the OTA channels for Flame Kitkat on 2.2, 2.1, and 2.0.
This appears to be the same issue as bug 1141633 for the Master branch.

The old builds currently available in the channel are:

2.2
20150309162503

2.1
20150309161206

2.0
20150309160225
[Blocking Requested - why for this release]:
Regression that will cause smoke tests to fail.


NI on No-Jun and Ben to take a look.
blocking-b2g: --- → 2.0?
Flags: needinfo?(npark)
Flags: needinfo?(bhearsum)
Keywords: regression, smoketest

Updated

4 years ago
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Keywords: qablocker
By using today's latest build, like comment #4 in bug 1141965, device is able to detect but device still can't download the package (bug 1142778).
I tried device update by using local OTA server, my device can detect/download/uncompress package which means today's build has no problem.
The problem here is that there is no xml file in server side. That's why device can't download package.
This might need Ben's help to fix.

Gaia-Rev        572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3db27b3c9298
Build-ID        20150312162502
Version         37.0
Device-Name     flame
FW-Release      4.4.2
I only disabled the OTA master branch, so I think there is some config related issue here.  Ben, could you take a look at this please?  Thanks!
Flags: needinfo?(npark)
Looks like this branch is still using the broken version of mozharness, so it's still submitting to the wrong place. I pushed https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/da3e96179c42. The first nightly to build with this changeset (hopefully later today) should get things fixed up.
Flags: needinfo?(bhearsum)
This is fixed now as far as I can tell. Update URLs such as https://aus4.mozilla.org/update/3/B2G/37.0a2/20150120002507/flame/en-US/nightly-b2g37/Boot2Gecko%202.2.0.0-prerelease%20%28SDK%2019%29/default/default/update.xml are returned the latest kitkat builds.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Keywords: verifyme

Comment 6

4 years ago
Hi Ben, v2.1 still cannot get the latest kitkat build, could you help with it again, thanks.
Flags: needinfo?(bhearsum)
(In reply to Mike Lien[:mlien] from comment #6)
> Hi Ben, v2.1 still cannot get the latest kitkat build, could you help with
> it again, thanks.

Ah, sorry. I forgot to update 2.0 and 2.1 with the new mozharness revision. I've done that now, the next set of nightlies should fix things up.
Flags: needinfo?(bhearsum)
Keywords: qaurgent, qawanted
I tested with nightly builds from 3/16 and confirmed that OTA works for 2.2, but NOT on 2.1 and 2.0.

Symptoms on 2.1 & 2.0: When asked the device to check for update, it displayed that there were no updates.

v2.0 build ID 20150316000201 -> failed
v2.1 build ID 20150316001204 -> failed
v2.2 build ID 20150316002502 -> updated successfully to build ID 20150317002504

Leaving qawanted keyword to re-test after new nightlies with fix from comment 7 have landed.
status-b2g-v2.2: affected → verified
Flags: needinfo?(ktucker)
Let's check this again tomorrow.
Flags: needinfo?(ktucker) → needinfo?(pcheng)
This issue is verified fixed on 2.0 and 2.1.

v2.0 build ID 20150317160202 -> updated successfully to build ID 20150318000203
v2.1 build ID 20150317161204 -> updated successfully to build ID 20150318001207
status-b2g-v2.0: affected → verified
status-b2g-v2.1: affected → verified
Flags: needinfo?(pcheng) → needinfo?(ktucker)
Keywords: qaurgent, qawanted, verifyme
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
I am seeing this in my Flame with 3.0. base image v18D, Spark and the 20150624160209 build. When checking for updates: "No updates are found", that's why I can't update to a newer build: I'm not receiving new OTA updates since then.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
That's a different issue, we have OTA's turned off for Flame 3.0 due to a Smoketest blocker
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
Thanks Peter for letting me know! Is there a bug or some other way to follow that issue so I'll be able to know when it's fixed?
Many thanks!
You need to log in before you can comment on or make changes to this bug.