tinderbox btek crash stacks

VERIFIED DUPLICATE of bug 116311

Status

()

--
blocker
VERIFIED DUPLICATE of bug 116311
17 years ago
13 years ago

People

(Reporter: jrgmorrison, Assigned: jrgmorrison)

Tracking

Trunk
mozilla0.9.8
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
Btek, the tinderbox that runs the page loading time test, has been crashing
randomly several times a day. I believe this originally started on Nov 27, 
but I may have that date wrong.

The crash always occurs on the first cycle of the test, when all of the content
has to pulled over the wire and put into the cache. The crash has not occurred
during the subsequent 'cached' cycles of the test, as far as I have seen.

So, dbaron wired up btek today to dump its stack when it crashes. Tonight, it 
crashed three times in a row. Stacks follow. All three stack traces end up in
(mangled name) Deallocate__Ct21XPCOM_StringAllocator1ZcPc+0x00000018, calling 
nsMemory::Free (although the problem is more likely in the callers, which seem
to be necko and imglib).


The first crash with a stack (and message leading up to the crash), at 22:55, is:


Running LayoutPerformanceTest ...
Begin: Sat Dec  8 22:55:53 2001
cmd = /export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla//dist/bin/mozilla-bin
-P tinderbox
"http://localhost/page-loader/loader.pl?delay=1000&nocache=0&maxcyc=9&timeout=30000"
End:   Sat Dec  8 23:01:14 2001
----------- Output from LayoutPerformanceTest ------------- 
  Document
http://localhost/page-loader/loader.pl?delay=1000&nocache=0&maxcyc=9&timeout=30000
loaded successfully
  Document
http://btek.nscp.aoltw.net/page-loader/loader.pl?c_part=-1&index=0&id=3C130AFD4C&maxcyc=9&replace=0&nocache=0&delay=1000&timeout=30000&c_intvl=NaN&s_ts=1007880957-993322&c_ts=1007880960155
loaded successfully
  Document
http://btek.nscp.aoltw.net/page-loader/loader.pl?c_part=1686&index=1&id=3C130AFD4C&maxcyc=9&replace=0&nocache=0&delay=1000&timeout=30000&c_intvl=1813&s_ts=1007880960-181680&c_ts=1007880962968&content=home.netscape.com
loaded successfully
... snip pages 2 to 4 ...
  Document
http://btek.nscp.aoltw.net/page-loader/loader.pl?c_part=999&index=5&id=3C130AFD4C&maxcyc=9&replace=0&nocache=0&delay=1000&timeout=30000&c_intvl=1136&s_ts=1007880969-560491&c_ts=1007880971676&content=www.moviefone.com
loaded successfully
  
  Program
/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla//dist/bin/mozilla-bin (pid
= 26160) received Segmentation fault signal.
  Stack:
  sigaction+0x00000268 [/lib/libc.so.6 +0x0001EC68]
  __libc_free+0x000000AA [/lib/libc.so.6 +0x00059FBA]
  PR_Free+0x00000018
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libnspr4.so
+0x00011C00]
  Free__12nsMemoryImplPv+0x00000018
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000A0630]
  Free__8nsMemoryPv+0x0000003C
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000CE40C]
  Deallocate__Ct21XPCOM_StringAllocator1ZcPc+0x00000018
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000D2F0C]
  UNKNOWN 0x8050b36
  PrepareForUseAsOutParam__14nsXPIDLCString+0x00000074
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000C7530]
  NSGetModule+0x000006FC
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libimglib2.so
+0x000040A8]
  NSGetModule+0x0000225D
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libimglib2.so
+0x00005C09]
  NSGetModule+0x000D2D86
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x000FE8F2]
  NSGetModule+0x000D315D
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x000FECC9]
  NSGetModule+0x00017408
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x00042F74]
  NSGetModule+0x000178BB
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x00043427]
  NSGetModule+0x000178BB
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x00043427]
  NSGetModule+0x000179E1
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x0004354D]
  NSGetModule+0x00097B9E
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x000C370A]
  NSGetModule+0x001A174C
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgkcontent.so
+0x001EC8CC]
  NSGetModule+0x0004578A
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x000712F6]
  NSGetModule+0x000FBABC
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgkcontent.so
+0x00146C3C]
  NSGetModule+0x000E457B
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgkcontent.so
+0x0012F6FB]
  NSGetModule+0x000E1497
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgkcontent.so
+0x0012C617]
  XPTC_InvokeByIndex+0x00000051
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000AE2A1]
  NSGetModule+0x0000A49D
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libxpconnect.so
+0x00028F29]
  NSGetModule+0x0000FE59
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libxpconnect.so
+0x0002E8E5]
  js_Invoke+0x00000536
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libmozjs.so
+0x00030F62]
  js_Interpret+0x0000707F
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libmozjs.so
+0x000389F7]
  js_Invoke+0x00000584
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libmozjs.so
+0x00030FB0]
  js_InternalInvoke+0x000000B0
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libmozjs.so
+0x000311AC]
  js_SetProperty+0x00000440
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libmozjs.so
+0x00044374]
  js_Interpret+0x000061D1
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libmozjs.so
+0x00037B49]
  js_Invoke+0x00000584
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libmozjs.so
+0x00030FB0]
  NSGetModule+0x00006193
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libxpconnect.so
+0x00024C1F]
  NSGetModule+0x00002E85
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libxpconnect.so
+0x00021911]
  XPTC_InvokeByIndex+0x000001F4
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000AE444]
  Stub3__14nsXPTCStubBase+0x00000022
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000AE4A6]
  NSGetModule+0x0000394B
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/liburiloader.so
+0x0000974B]
  NSGetModule+0x00002F7A
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/liburiloader.so
+0x00008D7A]
  NSGetModule+0x00002E3E
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/liburiloader.so
+0x00008C3E]
  NSGetModule+0x00002CC4
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/liburiloader.so
+0x00008AC4]
  NSGetModule+0x0000BF73
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libnecko.so
+0x0001DE0B]
  NSGetModule+0x00005305
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libimglib2.so
+0x00008CB1]
  NSGetModule+0x00004414
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libimglib2.so
+0x00007DC0]
  NSGetModule+0x0000336F
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libimglib2.so
+0x00006D1B]
  NSGetModule+0x0001C8C2
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libnecko.so
+0x0002E75A]
  NSGetModule+0x0004CEA3
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libnecko.so
+0x0005ED3B]
  NSGetModule+0x00060130
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libnecko.so
+0x00071FC8]
  NSGetModule+0x0000F6BC
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libnecko.so
+0x00021554]
  PL_HandleEvent+0x0000001F
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x00099807]
  PL_ProcessPendingEvents+0x00000067
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x00099723]
  ProcessPendingEvents__16nsEventQueueImpl+0x00000040
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x0009A658]
  Sleeping for 5 minutes.
  Type 'gdb
/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla//dist/bin/mozilla-bin
26160' to attatch your debugger to this thread.
  Done sleeping...




and the second time, at 23:37, with 


Running LayoutPerformanceTest ...
Begin: Sat Dec  8 23:37:03 2001
cmd = /export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla//dist/bin/mozilla-bin
-P tinderbox
"http://localhost/page-loader/loader.pl?delay=1000&nocache=0&maxcyc=9&timeout=30000"
End:   Sat Dec  8 23:43:10 2001
----------- Output from LayoutPerformanceTest ------------- 
  Document
http://localhost/page-loader/loader.pl?delay=1000&nocache=0&maxcyc=9&timeout=30000
loaded successfully
  Document
http://btek.nscp.aoltw.net/page-loader/loader.pl?c_part=-1&index=0&id=3C1314A30A&maxcyc=9&replace=0&nocache=0&delay=1000&timeout=30000&c_intvl=NaN&s_ts=1007883427-444184&c_ts=1007883429625
loaded successfully
  Document
http://btek.nscp.aoltw.net/page-loader/loader.pl?c_part=1681&index=1&id=3C1314A30A&maxcyc=9&replace=0&nocache=0&delay=1000&timeout=30000&c_intvl=1812&s_ts=1007883429-656321&c_ts=1007883432437&content=home.netscape.com
loaded successfully
... snip pages 2 to 22 ...
  Document
http://btek.nscp.aoltw.net/page-loader/loader.pl?c_part=840&index=23&id=3C1314A30A&maxcyc=9&replace=0&nocache=0&delay=1000&timeout=30000&c_intvl=976&s_ts=1007883486-555836&c_ts=1007883488506&content=www.ebay.com
loaded successfully
  
  Program
/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla//dist/bin/mozilla-bin (pid
= 11447) received Segmentation fault signal.
  Stack:
  sigaction+0x00000268 [/lib/libc.so.6 +0x0001EC68]
  __libc_free+0x000000AA [/lib/libc.so.6 +0x00059FBA]
  PR_Free+0x00000018
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libnspr4.so
+0x00011C00]
  Free__12nsMemoryImplPv+0x00000018
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000A0630]
  Free__8nsMemoryPv+0x0000003C
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000CE40C]
  Deallocate__Ct21XPCOM_StringAllocator1ZcPc+0x00000018
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000D2F0C]
  NSGetModule+0x0005E65E
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libnecko.so
+0x000704F6]
  NSGetModule+0x0000A6F6
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libnecko.so
+0x0001C58E]
  NSGetModule+0x0010A6C8
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x00136234]
  NSGetModule+0x0010E565
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x0013A0D1]
  NSGetModule+0x000A19F9
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x000CD565]
  NSGetModule+0x000E7D85
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x001138F1]
  NSGetModule+0x000EC97F
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x001184EB]
  NSGetModule+0x00046135
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/components/libgklayout.so
+0x00071CA1]
  Sleeping for 5 minutes.
  Type 'gdb
/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla//dist/bin/mozilla-bin
11447' to attatch your debugger to this thread.
  Done sleeping...



and the third time, at 00:46:


Running LayoutPerformanceTest ...
Begin: Sun Dec  9 00:46:14 2001
cmd = /export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla//dist/bin/mozilla-bin
-P tinderbox
"http://localhost/page-loader/loader.pl?delay=1000&nocache=0&maxcyc=9&timeout=30000"
End:   Sun Dec  9 00:52:53 2001
----------- Output from LayoutPerformanceTest ------------- 
  Document
http://localhost/page-loader/loader.pl?delay=1000&nocache=0&maxcyc=9&timeout=30000
loaded successfully
  Document
http://btek.nscp.aoltw.net/page-loader/loader.pl?c_part=-1&index=0&id=3C1324DB7E&maxcyc=9&replace=0&nocache=0&delay=1000&timeout=30000&c_intvl=NaN&s_ts=1007887579-858645&c_ts=1007887581965
loaded successfully
... snip pages 2 to 22 ...
  Document
http://btek.nscp.aoltw.net/page-loader/loader.pl?c_part=111&index=36&id=3C1324DB7E&maxcyc=9&replace=0&nocache=0&delay=1000&timeout=30000&c_intvl=250&s_ts=1007887668-263474&c_ts=1007887669491&content=www.google.com
loaded successfully
  
  Program
/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla//dist/bin/mozilla-bin (pid
= 14391) received Segmentation fault signal.
  Stack:
  sigaction+0x00000268 [/lib/libc.so.6 +0x0001EC68]
  __libc_free+0x000000AA [/lib/libc.so.6 +0x00059FBA]
  PR_Free+0x00000018
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libnspr4.so
+0x00011C00]
  Free__12nsMemoryImplPv+0x00000018
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000A0630]
  Free__8nsMemoryPv+0x0000003C
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000CE40C]
  Deallocate__Ct21XPCOM_StringAllocator1ZcPc+0x00000018
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000D2F0C]
  UNKNOWN 0x8050b36
  PrepareForUseAsOutParam__14nsXPIDLCString+0x00000074
[/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla/dist/bin/libxpcom.so
+0x000C7530]
  Sleeping for 5 minutes.
  Type 'gdb
/export/tinderbox/Linux_2.2.14-5.0smp_Depend/mozilla//dist/bin/mozilla-bin
14391' to attatch your debugger to this thread.
  Done sleeping...
(Assignee)

Comment 1

17 years ago
Created attachment 60990 [details]
stack traces from btek 12/08
The stacks have been varying a good bit, and one of them recently was in malloc.
 That's a sure sign of heap corruption.  We should probably try running the page
load tests under Purify.
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 3

17 years ago
I ran Purify (win2k) through the test a couple of times, but I didn't find a
smoking gun (Linux only?). I did find one FMM and a couple of UMR's and filed
bug 114356, bug 114366 and updated bug 68265.

Comment 4

17 years ago
-> 0.9.8
Target Milestone: mozilla0.9.7 → mozilla0.9.8
Severity: normal → blocker
->jrgm, since there's really nothing I can do about this, and I'm not sure who
else should own it.
Assignee: dbaron → jrgm
(Assignee)

Comment 6

17 years ago
related note (not that this will solve this crash but...) what's the magic
incantation that is needed in the build on btek to get symbols for all the 
modules (i.e., specific method names in the stack trace). This would help 
in tracking down other (less mysterious) crashes as they arise.
(Assignee)

Comment 7

17 years ago
bstell has Solaris purify data for this crash on bug 116311.

*** This bug has been marked as a duplicate of 116311 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.