[RTL][Call Screen]The "SIM 1/2" overlaps with the operator when incoming call in lockscreen.

RESOLVED DUPLICATE of bug 1142610

Status

P2
normal
RESOLVED DUPLICATE of bug 1142610
4 years ago
4 years ago

People

(Reporter: lulu.tian, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8577157 [details]
lockscreen_overlap.png

[1.Description]:
[RTL][Lock Screen]When we receive a call at lockscreen, the "SIM 1/2" overlaps with the operator  at top right.
See attachment:lockscreen_overlap.png

[2.Testing Steps]: 
1. Set your phone language to Arabic. 
2. Income call from contact/stranger in lockscreen or suspend mode. 
3. Check the incoming call page.

[3.Expected Result]: 
3. Nothing should overlap.

[4.Actual Result]: 
3. The "SIM 1/2"overlaps with the operator.

[5.Reproduction build]: 
Flame 2.2 build: affected
Build ID               20150312002501
Gaia Revision          572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gaia Date              2015-03-12 01:29:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/244e6ba3c20e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.040315
Firmware Date          Thu Mar 12 04:03:26 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: affected
Build ID               20150312160232
Gaia Revision          eabe35cf054d47087b37c1ca7db8143717fbd7f3
Gaia Date              2015-03-12 18:01:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/42afc7ef5ccb
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.194521
Firmware Date          Thu Mar 12 19:45:32 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15427
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
This is a screen that will pop-up every time someone receives a call, so nominating
blocking-b2g: --- → 2.2?
Priority: -- → P2
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15427/
Flags: in-moztrap+

Comment 3

4 years ago
Triage: should be dialer but Greg will check on lockscreen part
Component: Gaia::System::Lockscreen → Gaia::Dialer
Flags: needinfo?(gweng)
Delphine is also going to check if this happens on a single sim device and could have been reported already.
blocking-b2g: 2.2? → 2.2+
Created attachment 8579084 [details]
lockscreen check

LockScreen (*NOT* CallScreen) looks good as this attachment shows. However, I've noticed that the operator name in English is still LTR, not followed the RTL. Is this a bug should be fired, or it's an expected UI? NI Howie.

(Also, could we info QA that this screen is *NOT* LockScreen? We've seen at least three bugs titled LockScreen but they're actually CallScreen.
Flags: needinfo?(gweng) → needinfo?(hochang)

Comment 6

4 years ago
Seems like the operator name is not defined in the spec, ni ux.
Flags: needinfo?(hochang) → needinfo?(jelee)
Summary: [RTL][Lock Screen]The "SIM 1/2" overlaps with the operator when incoming call in lockscreen. → [RTL][Call Screen]The "SIM 1/2" overlaps with the operator when incoming call in lockscreen.

Comment 7

4 years ago
I believe this is for Carrie. Thanks Carrie!
Flags: needinfo?(jelee) → needinfo?(cawang)
Hi, 

According to the RTL rules, the English letters don't need to be reversed, we only reposition it with the RTL icons/strings. So in this case, it looks correct. Thanks!
Flags: needinfo?(cawang)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1142610
You need to log in before you can comment on or make changes to this bug.