Mail should compress folders when leaving, not when entering them

VERIFIED DUPLICATE of bug 114210

Status

MailNews Core
Backend
--
enhancement
VERIFIED DUPLICATE of bug 114210
17 years ago
10 years ago

People

(Reporter: Jesse Houwing, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Now when starting mozilla you get the question if you want to compress folders,
and as long as that's working you can't get your mail. Also when clicking on a
folder mozilla asks if it should compress it if you removed some messages the
last time you were there.

This is annoying. when I enter a folder I want to reed the messages in there
without having to answer that question.

COuld it be made so that 
a. you can have mozilla compress folders when you leave the
b. have mozilla compress folders as you exit mail/news (as NS 4 does it)
c. have mozilla compress folder in the background

But keeping the following things in mind:
a. people should be able to get what they want as fast as possible without
interruption

Also...

when you open mail news and let mozilla compress it immediately starts
doenloading mail and thus giving an errormessage. so:
b. mozilla should check on if compression is still working and if so wait with
the automatic download till it's done.

Updated

17 years ago
QA Contact: esther → sheelar

Comment 1

17 years ago
Request for enhancement or change in the behavior of compact folders.
Changing the bug status
Assignee: sspitzer → naving
Severity: normal → enhancement
Component: Mail Window Front End → Mail Back End
OS: Windows 2000 → All

Comment 2

17 years ago
changing status really. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Navin,
Bug 114210 also has a request to be able to Get Messages. The request and change
of behavior with 114210 will fix this bug too.
There has been two reports to be able to get messages as soon as you log in
instead of waiting till the compaction is done. 

Comment 4

17 years ago
Marking this bug as dup of bug 114210 based on reporter's initial comment in
that bug. These are same bugs because they both are requesting for compacting
folders on exit.

*** This bug has been marked as a duplicate of 114210 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verified as dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.